Jump to content
  • Checkout
  • Login
  • Get in touch


The e-commerce.

backup configuration


Recommended Posts



I have created a backup directory as directed, but every time I go to the backup tool I get a message that the directory does not exist and that I ahve to modify the configure.php file....how do I do that?


Nothing I do seems to work for me.


I have reset the write permission on the configure.php to allow it to be re-written.


appreciate some advice



Link to comment
Share on other sites

// Define the webserver and path parameters

// * DIR_FS_* = Filesystem directories (local/physical)

// * DIR_WS_* = Webserver directories (virtual/URL)

define('HTTP_SERVER', 'http://ozebook.com/osc'); // eg, http://localhost - should not be empty for productive servers

define('HTTPS_SERVER', 'https://ozebook.com/osc'); // eg, https://localhost - should not be empty for productive servers

define('ENABLE_SSL', false); // secure webserver for checkout procedure?

define('HTTP_COOKIE_DOMAIN', 'ozebook.com');

define('HTTPS_COOKIE_DOMAIN', 'ozebook.com');

define('HTTP_COOKIE_PATH', '/osc/');

define('HTTPS_COOKIE_PATH', '/osc/');

define('DIR_WS_HTTP_CATALOG', '/');

define('DIR_WS_HTTPS_CATALOG', '/');

define('DIR_WS_IMAGES', 'images/');

define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

define('DIR_WS_INCLUDES', 'includes/');


define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');


define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');



define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');


define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/');

Link to comment
Share on other sites

well, I fixed it, the required backup directory had to be in the root directory not the ocs directory......so i created an admin directory and a backup sub-dir and then it worked.


The documentation is misleading, it makes it look like it is referring to the admin dir in ocs.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...