Jump to content
  • Checkout
  • Login
  • Get in touch


The e-commerce.

Empty cart when using SSL


Recommended Posts

I'm trying to move a store from one server to another. The store has been running fine for several years now. Last night I moved the files and the database onto a new server and everything seemed to be working fine until I tried to checkout. After clicking checkout and signing in, I get a page that says that the cart is empty. If I click to see the contents of the shopping cart, there are still items in there. I tried turning SSL off and was able to get through to the payment info page.


I did not set up the original store but believe they used the MS1 release. I looked for the configuration->session area in admin but it doesn't exist. Also, there is no mention of cookies in the configuration.php file.


Here is a copy of its contents:




osCommerce, Open Source E-Commerce Solutions



Copyright © 2003 osCommerce


Released under the GNU General Public License



// Define the webserver and path parameters

// * DIR_FS_* = Filesystem directories (local/physical)

// * DIR_WS_* = Webserver directories (virtual/URL)

define('HTTP_SERVER', 'http://s12693.gridserver.com'); // eg, http://localhost - should not be empty for productive servers

define('HTTPS_SERVER', 'https://s12693.gridserver.com'); // eg, https://localhost - should not be empty for productive servers


define('ENABLE_SSL', true); // secure webserver for checkout procedure?

define('DIR_WS_CATALOG', '/catalog/'); // absolute path required

define('DIR_WS_IMAGES', 'images/');

define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

define('DIR_WS_INCLUDES', 'includes/');

define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');



define('DIR_FS_DOCUMENT_ROOT', '/home/12693/users/.home/domains/havaianasus.com/html/');

define('DIR_FS_CATALOG', '/home/12693/users/.home/domains/havaianasus.com/html/catalog/');

define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');



// define our database connection

define('DB_SERVER', 'xxxxx'); // eg, localhost - should not be empty for productive servers

define('DB_SERVER_USERNAME', 'xxxxx');

define('DB_SERVER_PASSWORD', 'xxxxx');

define('DB_DATABASE', 'xxxxx');

define('USE_PCONNECT', 'false'); // use persistent connections?

define('STORE_SESSIONS', ''); // leave empty '' for default handler or set to 'mysql'






mysql_select_db ($dbname);



The problem seems to happen when I switch the hostname to the real hostname. When it's define('HTTP_SERVER', 'http://s12693.gridserver.com'); it works but when I switch over the DNS server to point to the real name and change the setting to define('HTTP_SERVER', 'http://www.havaianasus.com'); and also for the HTTPS_SERVER it stops working.


Any ideas?

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...