Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

CGI Error -HTTP Header


Guest

Recommended Posts

I got this error message and I spend of 2 days trying to find problem and I am not able to find solution, can you point me to right direction. I am trying to run the osCommerce on Win2K and IIS 5.0 with mysql. the error message is

---

The specified CGI application misbehaved by not returning a complete set of HTTP headers. The headers it did return are:

 

I think It may have some to do with configure the IIS and I customize the HTTP Header and still no value returned. Please Help. thanks :?:

Link to comment
Share on other sites

This seems to be a configuration problem. Save yourself the trouble and install apache. IIS is something I can't help you with as I always avoid insecure programs ;-)

 

Do a google search on phptriad and you will find a complete solution for win2k.

 

HTH

You can't have everything. That's why trains have difficulty crossing oceans, and hippos did not adapt to fly. -- from the OpenBSD mailinglist.

Link to comment
Share on other sites

From the archives I have learned that running PHP in ISAPI mode solves a lot of problems.

 

Try a search with IIS PHP and look through the results.

 

I have never used IIS so I do not know what ISAPI mode is and how it can be installed that way. www.php.net will know though.

 

HTH

 

(Now I will cut'n'paste this to the several other threads about IIS, please people, use the search function BEFORE you post. With some 68.000 posts in the archives it is possible that you find an answer or at least learn a lot :-)

You can't have everything. That's why trains have difficulty crossing oceans, and hippos did not adapt to fly. -- from the OpenBSD mailinglist.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...