Jump to content
  • Checkout
  • Login
  • Get in touch


The e-commerce.

Brand new to OS


Recommended Posts


Been recommended to use osCommerce in my first attempts to set up a store.

My hosting company had this as one of thier scripts, so I installed using my host. I was asked a lot of questiopns about store name, password and so on. I wrote down all the info!


ANyway, when I try to get to my shop at www/maxelcat.co.uk/maxelshop/admin I get this:


Server Requirement Error: register_globals is disabled in your PHP configuration. This can be enabled in your php.ini configuration file or in the .htaccess file in your catalog directory.


NOw I can't find a directory called catalog anywhere in the installation.


What do I do now?


THanks in advance



Link to comment
Share on other sites

Your maxelshop directory is the catalog directory, only re-named. You probably won't have access to the php.ini file on a shared server but you can try adding


php_flag register_globals on


to your .htaccess file in the maxelshop directory.


If that doesn't work for you, you can apply the Register Globals Patch, available in the contributions section.

Link to comment
Share on other sites

I think I have worked out that the word catalog refers to the name of my store????


Anyway, if it does I hvae found a .htaccess file in a folder with the name of my store.


it looks like the below. Plese tell me what I should change.


many thanks


# $Id: .htaccess,v 1.3 2003/06/12 10:53:20 hpdl Exp $
# This is used with Apache WebServers
# For this to work, you must include the parameter 'Options' to
# the AllowOverride configuration
# Example:
# <Directory "/usr/local/apache/htdocs">
#   AllowOverride Options
# </Directory>
# 'All' with also work. (This configuration is in the
# apache/conf/httpd.conf file)

# The following makes adjustments to the SSL protocol for Internet
# Explorer browsers

<IfModule mod_setenvif.c>
 <IfDefine SSL>
SetEnvIf User-Agent ".*MSIE.*" \
		 nokeepalive ssl-unclean-shutdown \
		 downgrade-1.0 force-response-1.0

# If Search Engine Friendly URLs do not work, try enabling the
# following Apache configuration parameter
# AcceptPathInfo On

# Fix certain PHP values
# (commented out by default to prevent errors occuring on certain
# servers)
#<IfModule mod_php4.c>
#  php_value session.use_trans_sid 0
#  php_value register_globals 1

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...