Jump to content
  • Checkout
  • Login
  • Get in touch


The e-commerce.

Newbie re install on local host


Recommended Posts

Hi, I'm so sorry to be here, if I only had a few more hours I'm sure I'd find the help I need but I'm completely brain addled reading the first posting for the first 7 pages and waiting 5 hours for xampp to download.


I have changed apache to phpv4. I can reach localhost/xampp and no further. I'm not sure where or in what I should place the os stuff. I tried just placing the catalog folder in xampp's htdocs folder and couldn't get it to work there; I moved it to the xampp folder and no luck there either.


Rather than play around with folders and/or trawl even deeper into the first post, please can anyone give me a quick answer?


I'm sure the following error message has high signifigance so maybe it will help an even quicker/easier response?


FATAL ERROR: register_globals is disabled in php.ini, please enable it!


This comes from http://localhost/catalog/install/


It could take me forever to that file as I've searched for it using 'find' and it's not there :( I'm running Win98.


Help please!



Link to comment
Share on other sites

As to your problem - the error you are seeing tells you that register_globals is disabled in php.ini and you have to enable it. A simple Google search will bring back many results about what php.ini is and where it resides. Find the register_globals setting and change 'off' to 'on'.


I've found XAMPP to be somewhat buggy. You'd be far better off doing it properly and installing Apache, PHP and MySQL separately. The Windows installers that come with these three these days make very light work of getting them installed and all running together.


This is also an excellent tutorial:



Link to comment
Share on other sites

Well I now have Apache 2 installed, which works providing I repair it before using. PHP4 is installed, I've set the pathway and C drive/windows recognises it. I've got the SQL loaded but not sure if it's working yet - I'll worry about that later.


I followed all the config stuff in the php guidance but I don't think Apache recognises it. I copied the OS catalog file to htdocs in Apache but localhost doesn't recognise it. I have changed the php.ini file so register_globals is on but this no longer seems to be a problem. I have checked all the config files to make sure the links given point to the right folder and now I'm stuck.


It seems that there is so much that I have had to configue that I wonder if anyone can help me!:(


Thanks for the link though, it was some help despite being for win XP. If you or anyone else can offer any further advice I'd be very grateful.



Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...