Jump to content
  • Checkout
  • Login
  • Get in touch


The e-commerce.

Can't connect to database server


Recommended Posts

:'( Ok, you guys will have to forgive me, because I'm completely illiterate when it comes to OSCommerce. When I try to log into my admin page (www.thewitchshack.com/admin) I get this error:


Warning: mysql_connect() [function.mysql-connect]: Access denied for user 'thewi14'@'localhost' (using password: YES) in /home/thewi14/public_html/includes/functions/database.php on line 19

Unable to connect to database server!


I don't know where the password "YES" comes into this because that's never been our password!


I just noticed that if someone is on the Home Page, www.thewitchshack.net


the page looks fine until you click on any of the Category links, About Us, Contact Us, etc. and then that same error appears. I think the reason why the main page works is because I've edited it with Coffee Cup to add a couple of links and take a few of the tables off the page, but any page that I haven't edited myself will produce this error! I've emailed my host and they told me to create a unique log in in MySQL database, and i've done that but still get the error. Can anyone please give me some information if you know what can be done to fix this!!! Any help would be greatly appreciated!!!

Link to comment
Share on other sites

Well, it's often the case that using Coffee Cup messes a site up. Don't ask me why - I've just seen plenty of posts to that effect.


"Using Password YES" means simply that it is using the password supplied in the configure.php files when trying to connect to the database - it doesn't mean the password is "YES".


It's unusual, because when you get that error it usually takes the whole site down, including the index.php page. But if you have edited the Categories and hard-coded those links then that may explain why you are not getting the error on the homepage.


It's most likely the case that either your MySQL user name or password is incorrect in both of the configure.php files.



Link to comment
Share on other sites

OK thank you... LunarPages is our host and on the 10th we were required to change our log in to the site to access our account. The error didn't start occurring until late last night/this morning. Would that be the cause of the problem, and would it take 6 days for the error to start occurring after the password change to just log in to LunarPages? I have went and changed our password back to the original password we had but the error is still showing. :huh:

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...