Jump to content
  • Checkout
  • Login
  • Get in touch


The e-commerce.

Can't Upload Images


Recommended Posts

Hi All,


Before I toss my computer out the friggin window, will somebody please tell me why I can't upload images into a brand new install od osCommerce? I've tried the install at least 10 times in all different ways and while I can view the images that come with the stock products, I can't upload mine. Here is the latest install configure.php file from the /catalog/includes folder. The only thing I've done to it is overwrite the catalog with the latest STS contribution so that I can edit my storefront.


Please help!!




osCommerce, Open Source E-Commerce Solutions



Copyright © 2003 osCommerce


Released under the GNU General Public License



// Define the webserver and path parameters

// * DIR_FS_* = Filesystem directories (local/physical)

// * DIR_WS_* = Webserver directories (virtual/URL)

define('HTTP_SERVER', 'http://www.cobswebgifts.com'); // eg, http://localhost - should not be empty for productive servers

define('HTTPS_SERVER', ''); // eg, https://localhost - should not be empty for productive servers

define('ENABLE_SSL', false); // secure webserver for checkout procedure?

define('HTTP_COOKIE_DOMAIN', 'www.cobswebgifts.com');

define('HTTPS_COOKIE_DOMAIN', '');

define('HTTP_COOKIE_PATH', '/catalog/');

define('HTTPS_COOKIE_PATH', '');

define('DIR_WS_HTTP_CATALOG', '/catalog/');

define('DIR_WS_HTTPS_CATALOG', '');

define('DIR_WS_IMAGES', 'images/');

define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

define('DIR_WS_INCLUDES', 'includes/');

define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');


define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');

define('DIR_FS_CATALOG', '/catalog/');

define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');



// define our database connection

define('DB_SERVER', 'mysql'); // eg, localhost - should not be empty for productive servers

define('DB_SERVER_USERNAME', 'cobswebgifts');

define('DB_SERVER_PASSWORD', 'avery15');

define('DB_DATABASE', 'osCommerce');

define('USE_PCONNECT', 'true'); // use persistent connections?

define('STORE_SESSIONS', 'mysql'); // leave empty '' for default handler or set to 'mysql'


Link to comment
Share on other sites

I get a warning no file upload error. I tried just the image name (ex. image.gif) I tried putting a slash in front (ex. /image.gif ). I know the image is in the right directory because all of the sample images are in the same directory and I can see them on the test site.

Link to comment
Share on other sites

I'm having a similar problem.


Let me be the first to suggest setting the CHMOD values for your 'images' folder to 777.


Following that, I'd check for a .htaccess file in the 'images' folder - and probably try removing it if one exists.


I'd consider checking file space on your server - unlikely - but you might not have enough space.


Also check all the other permissions that need to be set properly - again, unlikely - but it won't do any harm.


If you're still having trouble - try asking your hosting company if they have anything stopping people uploading to the server through a web/PHP protocol - they might have something inhibiting such a thing.


If these don't work - then chances are it's either a slash or two wrong somewhere, or something's wrong in the configure file. (Although I couldn't tell you what)


Maybe even an error with the image file - I presume you've tried others, just to be safe.




hope some of this helps mate. I feel your pain!

Link to comment
Share on other sites

Also - just a thought, but you might want to try adding a trailing slash to the 'HTTP_COOKIE_DOMAIN' or 'HTTP_SERVER' value in the configure file.

Link to comment
Share on other sites

I tried it both ways but when I use the browse button it just looks at my hard drive, not the server where the image files are. Does the folders on my hard drive need to reflect the way they are on the server?

Link to comment
Share on other sites

Well then I've done that several times with no luck. Why would I be able to see the stock images but not the ones I upload? I tried using SmartFTP and putting the files right in the same directory (catalog/images) as the stock files.

Link to comment
Share on other sites

  • 4 weeks later...

I was searching for same and could not find anything like that after lotas of R&D i got it working.


If all that does not works like chmod images folder to 777 etc etc try this


in admin go to system > tools > server info


It will show you details of php




search for : always_populate_raw_post_data


If thats off thats the issue. You have to make that as on. You can do this via help of your hosting provers they will edit php.ini to make it on. Or You can use .htacces to make it on. Or you can create the php.ini in root folder and have this para as on



Hope that will help you

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...