Jump to content
  • Checkout
  • Login
  • Get in touch


The e-commerce.

Here is a solution for...


Recommended Posts

Hi all!

I had big problems getting my head around this error: Invalid argument supplied for foreach() that was showing up in Admin categories.php when I tried to copy or move products.


After searching the osCommerce forums it seems that this error is showing up in different contribs all over the place. I did not find the solution until searching with Google. And here is a solution that worked for me:





"foreach ($products_id as $product){"




"foreach ((array)$products_id as $product){"


That´s it. Worked for me :-)


Good luck!

Link to comment
Share on other sites

Magnus, please post stuff like this in the "tips and tricks" section. Thanks!



Simple 1-2-3 Intructions on how to get, install and configure SSL


The Google Sandbox explained


Simple to follow instructions on how to change the look of your OSC


How To Make A Horrible OSC Website


my toolbox: All things WordPress-related - All things Adobe-related - PHP Designer 2007 - Codecanyon Junkie - Crimson Editor - Winmerge - phpMyAdmin - WS_FTP


my installed contributions: Category Banners, File Upload feature-.77, Header Tags, Sort_Product_Attributes_1, XSellv2.3, Price Break 1.11.2, wishlist 3.5, rollover_category_images_v1.2, Short_Description_v2.1, UPSXML_v1_2_3, quickbooks qbi_v2_10, allprods v4.4, Mouseover-effect for image-buttons 1.0, Ultimate_SEO, AAP 1.41, Auto Select State Value, Fast Easy Checkout, Dynamic SiteMap v2.0, Image Magic, Links Manager 1.14, Featured Products, Customer Testimonials, Article Manager, FAQ System, and I'm sure more ...

Link to comment
Share on other sites

  • 2 weeks later...


This topic is now archived and is closed to further replies.

  • Create New...