Jump to content
  • Checkout
  • Login
  • Get in touch


The e-commerce.

"Error - Unable to determine the page link"


Recommended Posts

Dear Colleagues,


I am suddenly receiving a strange error message whenever I open the cart or my account pages.

"Error - Unable to determine the page link"


Could anybody let me know where I need to fix this and which parameter might be faulty?


Thanks loads,


Link to comment
Share on other sites

Your website host has probably upgraded PHP to the latest version which would cause the error as the latest version has


register_globals off


To use OsC, register_globals *must* be on...what this means is;


- ask you webhost to set register_globals on in php.ini

- if they won't do that then find another host ASAP



Link to comment
Share on other sites

globals is set to on on my server.


Have you checked this in the admin tool / tools / Server info???

Mark Evans

osCommerce Monkey & Lead Guitarist for "Sparky + the Monkeys" (Album on sale in all good record shops)



Software is like sex: It's better when it's free. (Linus Torvalds)

Link to comment
Share on other sites

Hi Sparky,


no my techsupport told me so.


But the Server Info reads:

System Linux rainbow.ispgateway.de 2.2.19-6.2.7 #12 Fri Oct 19 22:12:15 CEST 2001 i686 unknown

Build Date Feb 27 2002

Configure Command './configure' '--with-mysql=/usr/local/mysql' '--with-ttf' '--with-gd' '--with-ftp' '--with-pdflib' '--disable-force-cgi-redirect' '--enable-discard-path' '--enable-trans-sid' '--enable-ftp' '--enable-calendar' '--with-jpeg-dir=../jpeg-6b/' '--with-ttf' '--with-zlib-dir=../zlib-1.1.3/' '--with-png-dir=../libpng-1.0.6/' '--with-pgsql' '--with-gdbm' '--with-db2' '--with-ndbm' '--with-db' '--with-imap' '--with-kerberos' '--enable-bcmath' '--with-swf=/usr/lib/libswf' '--enable-memory-limit' '--with-dom' '--enable-xslt' '--with-xslt-sablot' '--with-curl' '--enable-dbase' '--enable-inline-optimization' '--with-gnu-ld'

Server API CGI

Virtual Directory Support disabled

Configuration File (php.ini) Path /usr/local/lib/php.ini

ZEND_DEBUG disabled

Thread Safety disabled



Not that I can read much out of this...


BUT: I've changed the $search_engine_safe = true to false in html_output.php:

function tep_href_link($page = '', $parameters = '', $connection = 'NONSSL', $add_session_id = true, $search_engine_safe = false) {


The it was working again. (wich is fine, BUT it used to work yesterday and the weeks before with exactly the setting $search_engine_safe = true.

The only thing that has changed since yesterday were a couple of httos-server related entries in configure.php and a few new product.


I'm really grateful for your help!


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...