Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Shipping problem with usps,ups works ok


jennwarr

Recommended Posts

Can some one help me with this problem? see below

 

 

 

Please select the preferred shipping method to use on this order. Please Select

 

United Parcel Service (1 x 5 lbs)

Next Day Air Early AM $61.53

Next Day Air $29.75

Next Day Air Saver $26.63

2nd Day Air $17.82

3 Day Select $14.37

Ground $11.21

 

United States Postal Service

An error occured with the USPS shipping calculations.

If you prefer to use USPS as your shipping method, please contact the store owner.

Link to comment
Share on other sites

That's a pretty vague error.

Could be a number of things.

1. username is wrong

2. password is wrong

3. server is wrong

4. USPS server is down.

5. They don't have your ZIP code registered on your account

6. Admin site -> Configuration -> Shipping and Packing

Your Country and Zip could might be entered wrong or not at all.

 

Hope this helps.

Link to comment
Share on other sites

Just did this today myself. As UPS rates increased USPS rates are very competitive. Hopefully you have received your web tools api user id already. Call the toll free number from the email you got when signing up for web tools. Tell them you are integrated shipping rates with a 3rd party shopping cart. Put userid in UserID box. Leave pass blank. Fill in the appropriate box below. Now try. Mine didn't work either until I called the number. Then it worked. I refreshed my checkout_shipping.php page while on the phone, and it was working.

Link to comment
Share on other sites

First go to http://www.usps.com/webtools/ and set up an account. This is the USER ID for the USPS shipping module

 

Next, send an email to [email protected] with the following:

 

Hellp,

 

Pleas move account number: YOURACCOUNTNUMBER to the production system. I am using OS Commerce with the USPS shipping module.

 

Regards,

 

Your name

 

It will take anywhere from 6-24 hours but once you get the reply choose production in your settings. There is no password required.

 

Joe

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...