Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

SSL for admin problem


prim

Recommended Posts

Hi,

 

i think I am kind of lost here. I was trying to make the admin going through SSL, but I am using shared SSL server so I bumped into some problems. I am getting an error that the catalog /images wasnt found and there are no images on the admin panel.

 

i think i am setting my options wrong in the configuration.php file

here is part of it. Anybody seeing somethign wrong ?

define('HTTP_SERVER', 'https://www.solokai.com'); // eg, http://localhost - should not be NULL for productive servers

 define('HTTPS_SERVER', 'https://secure.elinuxservers.com/~solokai'); // eg, https://localhost - should not be NULL for productive servers

 define('HTTP_CATALOG_SERVER', 'http://www.solokai.com/store');

 define('HTTPS_CATALOG_SERVER', 'https://secure.elinuxservers.com/~solokai/store');

 define('ENABLE_SSL', true); // secure webserver for administration tool

 define('ENABLE_SSL_CATALOG', true); // secure webserver for catalog module

 define('DIR_FS_DOCUMENT_ROOT', $DOCUMENT_ROOT); // where the pages are located on the server

 define('DIR_WS_ADMIN', '/store/admin/');

 define('DIR_FS_ADMIN', DIR_FS_DOCUMENT_ROOT . DIR_WS_ADMIN); // absolute pate required

 define('DIR_WS_CATALOG', '/store/');

 define('DIR_FS_CATALOG', DIR_FS_DOCUMENT_ROOT . DIR_WS_CATALOG);

 define('DIR_WS_IMAGES', DIR_WS_ADMIN . 'images/');

define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

 define('DIR_WS_CATALOG_IMAGES', DIR_WS_CATALOG . 'images/');

 

Please help :(

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...