Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

problems creating dev environment on local computer


pol2

Recommended Posts

Hello,

 

I am having problems creating a dev environment on my local computer. I am leveraging the osCommerce Professional Edition from David Mercer and following the steps to install mySQL, PHP, Apache and PHP Triad.

 

I initially had problems with creating a user from the command line so when I attempted to connect to mySQL using php code I received error messages regarding access denied for the requested user. I wasn't sure how to clear the mySQL datbase so in haste I decided to try to reinstall mySQL, PHP, Apache and PHP Triad again.

 

I initially could view the welcome page successfully testing Apache and PHP, but could not successfully connect to the mySQL account I created. After having 'reinstalled' the various elements, I seemed to have royally screwed up everything as I cannot even view the Apache welcome page correctly.

 

Every php file now creates a prompt asking whether or not I want to open or save the file.

 

Any thoughts on how to remove correctly all the installed instances locally and then resolve these errors?

 

Thanks for your help.

Link to comment
Share on other sites

Sounds like you need to check your Apache conf file as it doesn't seem to be parsing php files properly. Mime type maybe?

 

Iggy

Everything's funny but nothing's a joke...

Link to comment
Share on other sites

  • 9 months later...
Hello,

 

I am having problems creating a dev environment on my local computer. I am leveraging the osCommerce Professional Edition from David Mercer and following the steps to install mySQL, PHP, Apache and PHP Triad.

 

I initially had problems with creating a user from the command line so when I attempted to connect to mySQL using php code I received error messages regarding access denied for the requested user. I wasn't sure how to clear the mySQL datbase so in haste I decided to try to reinstall mySQL, PHP, Apache and PHP Triad again.

 

I initially could view the welcome page successfully testing Apache and PHP, but could not successfully connect to the mySQL account I created. After having 'reinstalled' the various elements, I seemed to have royally screwed up everything as I cannot even view the Apache welcome page correctly.

 

Every php file now creates a prompt asking whether or not I want to open or save the file.

 

Any thoughts on how to remove correctly all the installed instances locally and then resolve these errors?

 

Thanks for your help.

 

I went into the same story following the same book u followed, and i had so many troubles!! I can recommend that you skip this part of the book, uninstall everything u installed, and download the XAMPP package which contains (apache+php4+php+5+phpMyAdmin+mySql).. it has all what u need to set up ur environment and it doesn't harm your computer... you can find it here Free XAMPP Package!

Link to comment
Share on other sites

I went into the same story following the same book u followed, and i had so many troubles!! I can recommend that you skip this part of the book, uninstall everything u installed, and download the XAMPP package which contains (apache+php4+php+5+phpMyAdmin+mySql).. it has all what u need to set up ur environment and it doesn't harm your computer... you can find it here Free XAMPP Package!

WAMP is good too.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...