Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

image link in product description problems


Guest

Recommended Posts

In my product descriptions when I add an image link like this one:

 

<a target="_blank" href="nov2005/Face1.jpg">Click to See Image</a>

 

I get this as the link on the shop page:

http://www.mpm.org.au/shop_dev/"nov2005/Face1.jpg"

 

I know that the http:// etc is appearing as it's the image path in the configure file - but how do I stop it from appearing and just get a normal html link to appear.

 

Ascii codes don't seem to work either.

Link to comment
Share on other sites

perhaps your html editor inserts this code?

the image location is not used in the products description as a full url.

this becouse the imagesize funcion needs a relative path in order to work.

 

you could try it without a html editor and see if you can get it to work then. If so edit the settings of your editor, or use the full url as link.

Link to comment
Share on other sites

In my product descriptions when I add an image link like this one:

 

<a target="_blank" href="nov2005/Face1.jpg">Click to See Image</a>

 

I get this as the link on the shop page:

http://www.mpm.org.au/shop_dev/"nov2005/Face1.jpg"

 

I know that the http:// etc is appearing as it's the image path in the configure file - but how do I stop it from appearing and just get a normal html link to appear.

 

Ascii codes don't seem to work either.

 

Hey Mike,

 

The extra quotes are screwing you up. There's another link on your home page (bottom left) that's doing the same thing.

 

Noggins #1: Mike Delight

Mike Delight and friends drew 300 Faces for the inaugural block to raise money for Operation:Funnybone

$5.00AUD

 

<a href="http://www.mpm.org.au/shop/product_info.php?products_id=166">

Noggins #1: Mike Delight</b></a>

<br>

<a target=""_blank"" href=""http://www.livejournal.com/mikedelight"">

Mike Delight</a> and friends drew 300 Faces for the inaugural block to raise money for

<a target=""_blank"" href=""http://www.funnybone.org.au/"">Operation:Funnybone</a>

 

Check in your admin>product's description to see if the errant quotes are in there.

 

jon

It's all just ones and zeros....

Link to comment
Share on other sites

I seem to have gotten over the image link problem (I hadn't added the folder 'images' into the path it seems)

 

But yeah, those normal links are a mystery.

 

This is what I get from my html editor (tinymce)

 

<a href=""http://www.livejournal.com/mikedelight"" target=""_blank"">Mike Delight</a> and friends drew 300 Faces for the inaugural block to raise money for <a href=""http://www.funnybone.org.au/"" target=""_blank"">Operation:Funnybone</a> <br />

 

But on the webpage each link has the shop url added as you noted.

Link to comment
Share on other sites

I don't know Tinymce but I do recognise it's a contribution that people like a lot. When you enter your URLs into the Tinymce html editor for your product description, are you keying in those links with quotes around them?

 

If so, it appears Tinymce is already set up to add those quotes for output. As a result (and this is just a theory), you are inputting quotes and Tinymce, by default, is inputting quotes.

 

This could explain why double "" are showing up. Give it a try.

 

Edit: Here is the part of the Tinymce FAQ. It may help :)

http://tinymce.moxiecode.com/tinymce/docs/faq.html

 

jon

It's all just ones and zeros....

Link to comment
Share on other sites

I don't know, since I have not used these 2 contributions, but I did review some of their documentation. You have two issues that show up with one product where you have added an absolute link within its description:

 

1. Double quotes (Tinymce)

2. An undesireable path preceding your link (EasyPopulate, or how you entered the description in the upload file)

 

I would approach them this way:

 

1. Back up your site (FTP down to local hard drive)

2. Back up your data base through Admin

3. Turn the Magic Quotes off.

4. View browser source on Noggins to see if double quotes for this product are gone.

 

Next, if the path problem is still there:

 

Check the file you use to upload for EasyPopulate, specifically, the v_products_description_1

field. Is that path there? If so, remove it so it won't upload again. If the path is not there, it's being added server-side and you need to check a path setting with Admin/EasyPopulate (if there is one).

 

Give it a go. The worse that can happen is you need to restore the data base.

 

This is the best I can offer based on my limited experience but troubleshooting is troubleshooting and this is how I would go about it.

 

jon

It's all just ones and zeros....

Link to comment
Share on other sites

With respect to turning Magic Quotes off, I wasn't referring to disabling it for PHP completely, just within your Tinymce contribution within /admin?

 

At any rate, aside from the double quotes issue, have you resolved your path problem?

 

jon

It's all just ones and zeros....

Link to comment
Share on other sites

The double quotes seems to be the path problem.

 

I can edit the links through the product info page and they appear fine. (If I add " then I get the path problem again)

 

It's when I upload through Easy Populate that the magic quotes are appearing.

 

How do I turn the magic quotes off for Tinymce - I don't have an admin control for it.

Link to comment
Share on other sites

So you have identified that EasyPopulate is taking your upload file, interpreting links you've keyed in your description field, and doubling the quotes. This isn't a TinyMCE problem.

 

You never answered if you are putting quotes around your links in your upload file.

 

I haven't used EasyPopulate yet but double quotes post upload are a problem. Searching the forum for "double quote" yields this. Please read the entire (short) thread before changing code :)

 

http://www.oscommerce.com/forums/index.php?sho...c=71632&hl=

 

jon

It's all just ones and zeros....

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...