Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

email via smtp


CGhoST

Recommended Posts

Hi everyone

 

Am i the only one from millions of people using oscommerce that has problems with SMTP?

 

I have setup oscommerce on xampp and email options i have set SMTP.

 

These are my settings:

 

E-Mail Transport Method - smtp

E-Mail Linefeeds - CRLF

Use MIME HTML When Sending Emails - true

Verify E-Mail Addresses Through DNS - false

Send E-Mails - true

 

I have a SMTP server setup properly but i can't get any emails sent.

 

I have setup the smtp server in php.ini yet nothing works.

 

Am i missing something or doing something wrong?

 

Please help

Link to comment
Share on other sites

I am working through this issue right now.

 

Create just a regular formmail page and see if the smtp server can send outgoing mail - my initial problem was that I could send email from the contact us page but not order emails and emails from the admin section.

 

If that works, then you are probably on a server that uses smtp authentication and so you'll have to add some code in. I am using smtp auth v1.2 found here:

 

SMTP Contribution

 

Now I can send email from front and back end and the order process does not crash, but I don't yet receive email about the order either as a customer or admin.

Link to comment
Share on other sites

I fixed the problem I was having with my emails. Here's what I sent to my ISP:

 

===============================

 

Q: I have found what the problem is. Your smtp server requires authorization when sending emails from the customer order section and admin section of osCommerce but not from the Contact Us link on the main site page. A contribution to handle this incompatability is here:

 

http://www.oscommerce.com/community/contributions,4013

 

Please note the addition to it which requires you to change a line of code in email.php. From the thread:

 

in includes/classes/email.php and admin/includes/classes/email.php where edited in phpMailer4osC installation, replace; $pMail->IsHTML(true); with; $pMail->IsHTML(false);

 

This probably rates inclusion into your FAQs on osCommerce.

 

================================

 

The nice thing about the contribution used above is that you can still use the send extra order emails line in your admin section.

 

I hope this helps....

Link to comment
Share on other sites

I had emailing issues too just like yourself until I did this. Your settings in the Admin panel are correct but the PHP.ini file needs to be changed. This is for WIN based servers only (as far as I know).

 

First, confirm that you have a WIN based server by going to the Admin Panel > Tools > Server Info. Near the top, it should say Hosting OS: WINxx

 

Now, look at your root folder on your ftp, where your Catalog folder is stored and download the php.ini file onto your desktop. Open it using notepad and on your keyboard press CTRL+F (Find) and search for [mail function] exactly how I typed it here. By default, it uses your hosting companies SMTP here but it should be your domain/emailing server written here.

 

Before:

 

[mail function]

; For Win32 only.

SMTP=mail.hsphere.cc

 

; For Win32 only.

[email protected]

 

After:

 

[mail function]

; For Win32 only.

SMTP=mail.yourdomainhere.com

 

; For Win32 only.

[email protected]

 

After making the change, save the PHP.ini file and overwrite your PHP.ini file on your server by uploading it into the same root folder. After, test to see if you are getting emails by going to Admin Panel>Tools>Send Email. You should get an email after about 3-5 minutes. If not, try putting SMTP_PORT = 25 (directly underneath the SMTP=mail.yourdomainhere.com)

 

The SMTP is not always going to be your email domain, but give it a shot...got mine to work. Goodluck

Edited by ehong33234
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...