Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Advanced Search Results Have Bad URLs


maksum

Recommended Posts

Searching on my site will generate results, but clicking on those results won't get you anywhere. That's because the URLs on the results are being generated in this format:

 

...product_info.php/manufacturers_id//products_id/118

 

I believe it should be more like this:

 

...product_info.php?manufacturers_id=&products_id=118

 

Apparently instead of question marks, equal signs, and ampersands it's just throwing in slashes.

 

You're welcome to experience this yourself to see what I mean at:

 

www.shopdigitalblue.com

 

Simply click on "Search" at the top, type something in that will give you results, and look at the bad URLs.

 

Has anyone else run into this? Have any idea how I can remedy this? I would very much appreciate any insights anyone has to offer.

 

Thanks.

Link to comment
Share on other sites

Mike, when I followed your instructions, I get: these results ... sorry for including your session ID, no big deal ... doesn't matter. Anyway ...

 

I am not sure what you're talking about.

Jason

 

Simple 1-2-3 Intructions on how to get, install and configure SSL

 

The Google Sandbox explained

 

Simple to follow instructions on how to change the look of your OSC

 

How To Make A Horrible OSC Website

 

my toolbox: All things WordPress-related - All things Adobe-related - PHP Designer 2007 - Codecanyon Junkie - Crimson Editor - Winmerge - phpMyAdmin - WS_FTP

 

my installed contributions: Category Banners, File Upload feature-.77, Header Tags, Sort_Product_Attributes_1, XSellv2.3, Price Break 1.11.2, wishlist 3.5, rollover_category_images_v1.2, Short_Description_v2.1, UPSXML_v1_2_3, quickbooks qbi_v2_10, allprods v4.4, Mouseover-effect for image-buttons 1.0, Ultimate_SEO, AAP 1.41, Auto Select State Value, Fast Easy Checkout, Dynamic SiteMap v2.0, Image Magic, Links Manager 1.14, Featured Products, Customer Testimonials, Article Manager, FAQ System, and I'm sure more ...

Link to comment
Share on other sites

sorry I wasn't clear. Ok, now that you have those results, try clicking on the products that come up.

 

The search works fine. It brings up products that match your search criteria. But clicking on those products gives you the bad links.

 

That more clear?

 

Thanks,

 

Mike

Link to comment
Share on other sites

While I'm at it... here's another question. If I were to simply replace one or more of the files on my site with the original oscommerce install, which file(s) would I change that would likely fix this. That might be a place to start.

 

I'll start experimenting, but if someone at least knows the file that the problem is likely located, that would be helpful as well.

 

Thanks,

 

Mike

Link to comment
Share on other sites

Go to your admin tool --- www.shopdigitalblue.com/admin, and click configuration. Turn Search Engine Friendly URL's to off.

 

I don't know if there's something messed up in your includes/configure.php, 'cause when I hover over one of the advanced search results product links, there are 2 slashes // after manufacturers_id, when there should only be one.

 

Anyway, try turning those Search Engine Friendly URL's off, and that should do it. If you want better URL's, you can install Chemo's Ultimate SEO URL contribution later.

 

Good luck.

Jason

 

Simple 1-2-3 Intructions on how to get, install and configure SSL

 

The Google Sandbox explained

 

Simple to follow instructions on how to change the look of your OSC

 

How To Make A Horrible OSC Website

 

my toolbox: All things WordPress-related - All things Adobe-related - PHP Designer 2007 - Codecanyon Junkie - Crimson Editor - Winmerge - phpMyAdmin - WS_FTP

 

my installed contributions: Category Banners, File Upload feature-.77, Header Tags, Sort_Product_Attributes_1, XSellv2.3, Price Break 1.11.2, wishlist 3.5, rollover_category_images_v1.2, Short_Description_v2.1, UPSXML_v1_2_3, quickbooks qbi_v2_10, allprods v4.4, Mouseover-effect for image-buttons 1.0, Ultimate_SEO, AAP 1.41, Auto Select State Value, Fast Easy Checkout, Dynamic SiteMap v2.0, Image Magic, Links Manager 1.14, Featured Products, Customer Testimonials, Article Manager, FAQ System, and I'm sure more ...

Link to comment
Share on other sites

Go to your admin tool --- www.shopdigitalblue.com/admin, and click configuration. Turn Search Engine Friendly URL's to off.

 

Jason,

 

That did the trick. Thanks so much. Thanks also for the recommend on the SEO URL contrib.

 

Mike

Link to comment
Share on other sites

  • 4 months later...

Sorry to open a dead topic, but I have a question on this:

 

Is there a way to fix this without turning Search-engine safe URLs off? The search engines dont like question marks, and installing CHemos SEO URL can be a somewhat involved process. There has to be a place in the code where there is an extra backslash that was added accidentally...I jstu dont know where to find it!

 

Any help would be appreciated!

 

Josh

Link to comment
Share on other sites

Bump...Anybody:

 

Sorry to open a dead topic, but I have a question on this:

 

Is there a way to fix this without turning Search-engine safe URLs off? The search engines dont like question marks, and installing CHemos SEO URL can be a somewhat involved process. There has to be a place in the code where there is an extra backslash that was added accidentally...I jstu dont know where to find it!

 

Any help would be appreciated!

Josh

Link to comment
Share on other sites

Sorry to open a dead topic, but I have a question on this:

 

Is there a way to fix this without turning Search-engine safe URLs off? The search engines dont like question marks, and installing CHemos SEO URL can be a somewhat involved process. There has to be a place in the code where there is an extra backslash that was added accidentally...I jstu dont know where to find it!

 

Any help would be appreciated!

 

Josh

There is no quick fix for that so I would recommend to install one of the seo url contributions. Also there is no point using the stock osc sef urls because they do not provide meaningful names for products/categories. So why using it? for aesthetic reasons?

Link to comment
Share on other sites

Actually, I just found an EASY fix for this. Here it is, once again for the archives:

 

If you are having trouble with advanced search giving results with bad URLs (ie, the format has 2 // after the manufacturere_id), do this:

- Backup your catalog/advanced_search.php. ALWAYS backup.

- Open the file catalog/advanced_search.php. Scroll down to this block of text and detele it. Just totally remove it:

<tr>

<td class="fieldKey"><?php echo ENTRY_MANUFACTURERS; ?></td>

<td class="fieldValue"><?php echo tep_draw_pull_down_menu('manufacturers_id', tep_get_manufacturers(array(array('id' => '', 'text' => TEXT_ALL_MANUFACTURERS)))); ?></td>

</tr>

 

Make sure and get the <tr> and </tr> at the beginning and end. Save this and your search engine will no longer include the manufacturer parameter in its search. In the process, you will remove the glitch of the double // that seems to harangue many people.

 

Upon experimenting some more, the real problem comes from the "All Manufacturers" text that it enters. Its just a text tag and has no meaning, no data attached to it (ie, a manufacturer id string). For a more involved method of using the manufacturer parameter in advanced search *properly*, one could simply set the code so that the page defaults to one of the manufacturers and this would also give successful results.

 

Hope this is helpful to somebody else out there...

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...