Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Site displaying different between Mozilla vs IE 7


JDesigns

Recommended Posts

Ive been working with a few staff modifying a oscommerce template and I ran into a problem, I was working with mozilla the whole time and the site displays properly, but in IE it only shows 1 product on the home page with the footer not loading vs mozilla showing it correctly. I'm new to oscommerce obviously and I've looked over all the files pertaining to the index with the product listing, but i must be missing something. Can some one help out maybe I'm missing looking over a file that can be the source of the problem.

 

 

thanks

Link to comment
Share on other sites

Hi JDesigns,

 

I'm really not the right person to even attempt to answer you question but....

 

I have encountered the same problem at times trying to modify scripts like osCommerce. I think (I'm almost 88 and some times I forget, lol) I made a post here like yours a few weeks ago but maybe it was something else.

 

I also use FireFox as my primary Browser and often Check my Changes using Internet Explorer just to see how the other side see things.

 

Anyway, Some times I end up with Bad results - no results or just different results than what I viewed in FireFox.

 

That is when I view it on the same computer that I created it -- I mean I modify the script on computer A - look at the Changes with FireFox on computer A, then look at it with Internet Explorer on Computer A and it is different or no change has occurred.

 

Then I'll ask some one else to view it (from a different computer) and all is fine. I don't know why this happens to me but it does and maybe the same thing is happening to you. Ask a friend to view or if your able to check it at the Office and then at Home.

 

I hope I was of some help?

 

yamiacaveman

Link to comment
Share on other sites

Hi JDesigns,

 

I'm really not the right person to even attempt to answer you question but....

 

I have encountered the same problem at times trying to modify scripts like osCommerce. I think (I'm almost 88 and some times I forget, lol) I made a post here like yours a few weeks ago but maybe it was something else.

 

I also use FireFox as my primary Browser and often Check my Changes using Internet Explorer just to see how the other side see things.

 

Anyway, Some times I end up with Bad results - no results or just different results than what I viewed in FireFox.

 

That is when I view it on the same computer that I created it -- I mean I modify the script on computer A - look at the Changes with FireFox on computer A, then look at it with Internet Explorer on Computer A and it is different or no change has occurred.

 

Then I'll ask some one else to view it (from a different computer) and all is fine. I don't know why this happens to me but it does and maybe the same thing is happening to you. Ask a friend to view or if your able to check it at the Office and then at Home.

 

I hope I was of some help?

 

yamiacaveman

 

different browsers always render html code differently (as with javascript), if they did not life would be a lot easier.

So any change to your outputted html should be verified in all browsers you deem important.

And don't forget to clear your browser cache before you do.

Treasurer MFC

Link to comment
Share on other sites

Well see thats just it, I actually learned about this problem viewing the website via another computer, that has IE as default browser, and it seems the only page with the error is the front page, its set to show 4 recently added products and it shows one with a visiable broken table, and doesnt load the footer, but with Mozilla its fine. I recently had this project dumped on me from another client, and no little about oscommerce and find in some cases it's best to ask. I also noticed any other page besides the index loads fine, leading me to ask what files are used to list the recently added products on the index page.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...