Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

register_global problem.


msole

Recommended Posts

Error Messages . . . . .

 

Server Requirement Error: register_globals is disabled in your PHP configuration. This can be enabled in your php.ini configuration file or in the .htaccess file in your catalog directory. ( error I get trying to enter www.mydomain.com/catalog

 

and

 

FATAL ERROR: register_globals is disabled in php.ini, please enable it! ( error I get trying to enter www.mydomain.com/catalog/install

 

I tried many ways and search all these threads but I didn't get much out of it.

 

Vger said in one of the threads that its suppose to be off not to be on. While it says it has to be on, when I try installing. Can someone please tell me how to fix this problem?

Link to comment
Share on other sites

In the osCommerce package you will find a .htaccess file in the /catalog/ directory - open this in a text editor and change:

 

#<IfModule mod_php4.c>
#  php_value session.use_trans_sid 0
#  php_value register_globals 1
#</IfModule>

 

to:

 

<IfModule mod_php4.c>
#  php_value session.use_trans_sid 0
 php_value register_globals 1
</IfModule>

 

 

Upload the file to your server :)

 

 

Sonia

Link to comment
Share on other sites

Error Messages . . . . .

 

Server Requirement Error: register_globals is disabled in your PHP configuration. This can be enabled in your php.ini configuration file or in the .htaccess file in your catalog directory. ( error I get trying to enter www.mydomain.com/catalog

 

and

 

FATAL ERROR: register_globals is disabled in php.ini, please enable it! ( error I get trying to enter www.mydomain.com/catalog/install

 

I tried many ways and search all these threads but I didn't get much out of it.

 

Vger said in one of the threads that its suppose to be off not to be on. While it says it has to be on, when I try installing. Can someone please tell me how to fix this problem?

 

 

also where is the php.ini file?

Link to comment
Share on other sites

In the osCommerce package you will find a .htaccess file in the /catalog/ directory - open this in a text editor and change:

 

#<IfModule mod_php4.c>
#  php_value session.use_trans_sid 0
#  php_value register_globals 1
#</IfModule>

 

to:

 

<IfModule mod_php4.c>
#  php_value session.use_trans_sid 0
 php_value register_globals 1
</IfModule>

Upload the file to your server :)

Sonia

 

 

I just did that, but it still says the same thing. Am I suppose to restart the website? If I need to how do I do that?

Link to comment
Share on other sites

Does not always work (depends on your server)

 

You can:

 

Ask your host to enable it for your web space

 

or

 

Install register:globals patches you will find in contributions

 

 

 

 

Sonia

Link to comment
Share on other sites

  • 2 weeks later...

Hi

 

Ohhhh i'm soo having the exact same problem and submitted a ticket to my host 2 days ago! someone plssssss tell me how i can fix this as i'd like to try oscommerce out.

 

This is the error i get

 

Server Requirement Error: register_globals is disabled in your PHP configuration. This can be enabled in your php.ini configuration file or in the .htaccess file in your catalog directory.

 

I'm very very new - to be honest this is my second post and would truly appreciate it someone could post simple instructions as to how i can go about fixing this issue.

 

Much appreciated.

 

Thanks

Antz :'(

Link to comment
Share on other sites

I also can into this problem today as I'm moving my store to a new server.

 

This might help you: (I used the "For PHPsuexec servers" option and it worked for me!)

 

 

 

For those wishing to turn on or turn off PHP register_globals, you can edit files within your account to set this setting locally. Depending on if the machine you are on is using PHPSUEXEC or not will determine which method you use.

 

For NON-PHPsuexec servers:

1) Using a file manager from cPanel or FTP: locate the ".htaccess" file located in each directory.

*NOTE* If you want this setting for your entire site, edit the .htaccess in public_html if not, edit the .htaccess file within the folder you want it for.

 

2) Once you have this file opened with an editor, add the below line onto a new line in the file:

php_flag register_globals off

(Change it to On to turn it on)

 

3) Save the file, and your done!

 

For PHPsuexec servers:

1) Using a file manager from cPanel or FTP: Create a file named "php.ini" in the directory of your choice or in "public_html" for your entire site.

 

2) Now open it with a text editor and add the following line:

register_globals = Off

(Change to On if you want this enabled)

 

3) Now save the file, and your done!

 

This process can be followed for many other similar php settings. Bear in mind that for a phpsuexec file, a local php.ini file only affects the directory that it's directly put in. Subdirectories are not affectd.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...