Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

S.O.S Contributions leaves language and go English


nelsonevp

Recommended Posts

Hello ,

 

I have a little problem. I have the contribution: "osplayer v2.1" for Mp3 music, the unique problem is when the customer use the file : popup_oscplayer in order to listen the music, after it the shop continues always in English and leave the original language in which the client use it (I have 5 languages) Eg. Spanish, French, Italian, German and in these cases the shop continues after in English.

( I work many hours but unfortunately I can not find the solution) Please if you have time for the solution I appreciate a lot.

 

The whole file popup_oscplayer.php is:

 

<?php

/*

$Id: popup_oscplayer.php,v 2.00 09/11/2004 16:00:10 ManMAchine Exp $

 

Mp3 player module for osCommerce, Open Source E-Commerce Solutions

http://www.oscommerce.com

 

osPlayer - ManMAchine - 09/11/2004 [email protected]

Copyright ? 2004 ManMAchine

 

Released under the GNU General Public License

*/

 

//********************************************

//********************************************

// oscPlayer V2 ? Manmachine

//********************************************

//********************************************

 

?>

 

<!doctype html public "-//W3C//DTD HTML 4.01 Transitional//EN">

<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="fr" lang="fr">

<head>

<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />

<title>Mp3 preview</title>

</head>

<style type="text/css"><!--

 

body { margin:0; padding:0; background: #fff; }

 

//--></style>

<body>

 

<!--swf player file -->

 

<object type="application/x-shockwave-flash" data="osc_player.swf?mp3id=<?php echo $_GET['product_id'];?>&autoplay=<?php echo $_GET['autoplay'];?>"

width="193" height="265">

<param name="quality" value="high" />

<param name="bgcolor" value="#ffffff" />

<param name="movie" value="osc_player.swf?mp3id=<?php echo $_GET['product_id'];?>&autoplay=<?php echo $_GET['autoplay'];?>"/>

<a href=http://www.macromedia.com/shockwave/download/download.cgi?P1_Prod_Version=ShockwaveFlash target="blank"><img src="images/icons/noflash.gif" width="88" height="31" vspace="5" hspace="50" alt="install flash player plugin"/></a>

</object>

</body>

</html>

 

Thanks and best regards, Nelson

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...