Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Cannot upload thumbnails


whiteblazer01

Recommended Posts

I cannot upload any images to set as thumbnails for my categories (or any images for that matter). I think it's a matter of write permission, but I don't know where.

 

Any advice?

 

Thanks!

 

Paul

 

If it is write permission, there are two ways to fix it.

 

Log onto your host cpanel and change the permissions of your folders to something like 755 or 777.

 

Or use a good ftp client to long on and change them in bulk from that program.

 

Note: Some hosts do not allow you to change the attributes of configure.php through ftp. You have to log directly onto the cpanel to do that.

Just between us, remember there are only 10 kinds of people in the world; those who understand binary and those who don't!!

 

Remember, learning is a "do-it-yourself" experience; although, not necessarily a "do-it-BY-yourself" experience.

 

The quickest way to learn is to forget to BACKUP!

Link to comment
Share on other sites

Thanks for your reply. My Catalog/Images directory is set to 777, but I this did not solve the problem.

 

I do have full permission with my ftp program and my web host to change settings.

 

 

If you are uploading your images from the admin section are they by any chance

 

Going into an uexpected location in your directory?

 

Do you get a specific error message?

 

Do they showup in admin but not in catalog?

Just between us, remember there are only 10 kinds of people in the world; those who understand binary and those who don't!!

 

Remember, learning is a "do-it-yourself" experience; although, not necessarily a "do-it-BY-yourself" experience.

 

The quickest way to learn is to forget to BACKUP!

Link to comment
Share on other sites

I am uploading from the admin, and it doesn't even try to upload the images. I get an error message at the top saying "Warning: No file uploaded."

 

EDIT: This also does not work for inserting images into the product page.

 

 

The only other thing I can think of at this time is to make sure all your upline directories are set with the proper permissions. For example, you set you images directory, but what is your catalog set at?

 

I'm running out of my knowledge base here, I hope someelse pops in.

Just between us, remember there are only 10 kinds of people in the world; those who understand binary and those who don't!!

 

Remember, learning is a "do-it-yourself" experience; although, not necessarily a "do-it-BY-yourself" experience.

 

The quickest way to learn is to forget to BACKUP!

Link to comment
Share on other sites

I can't connect to my site now, I guess it's down for a few minutes.

 

While I'm asking questions, I have a few more....

 

For the product attributes - how can I make the product attribute page in the admin directory show more than 10 at a time? I want it to show everything on one page (even if there are 100+ attributes). It seems the design/layout is not very easy to work with.

 

Also, how can I sort the orderthe attributes/options are shown on the product page? I have color as an option, but they are in a different order than I would like. It seems as if it is sorted according to which order I insert them into the attribute page.

 

Thanks!

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...