Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

HELP! 24 hrs still no solution! I've tried everything...


lbcampagna

Recommended Posts

See: www.lawatches.com - this is a new install of OSC.

when you hit 'confirm order' and it goes to paypal, the response comes back with the 'payment for' field complete with the company name and not the products from the cart.

 

Try:

put a product in the cart.

create and account or use [email protected] pw: password

choose paypal payment option and hit confirm

 

You'll see the paypal response before needing to log into paypal.

 

What is the variable for products? I think the wrong variable is being passed to paypal.

 

Any help would be much appreciated. I've been at this for 24 hrs now.

looked at paypal.php file, the error might be there but don't know what correct variable should be.

Link to comment
Share on other sites

See: www.lawatches.com - this is a new install of OSC.

when you hit 'confirm order' and it goes to paypal, the response comes back with the 'payment for' field complete with the company name and not the products from the cart.

 

Try:

put a product in the cart.

create and account or use [email protected] pw: password

choose paypal payment option and hit confirm

 

You'll see the paypal response before needing to log into paypal.

 

What is the variable for products? I think the wrong variable is being passed to paypal.

 

Any help would be much appreciated. I've been at this for 24 hrs now.

looked at paypal.php file, the error might be there but don't know what correct variable should be.

I'm not in the middle of nowhere, but I can see it from here!

Link to comment
Share on other sites

The first thing I would look at is what other contributions you have installed. I've found that many times other contributions will cause this to act up. I'm currently working on a problem where WPP is passing the wrong total to Paypal. I know why it's doing it I just haven't found the right work around yet. Anyway, Check your other contributions, one of them may be interferring with this one.

I'm not in the middle of nowhere, but I can see it from here!

Link to comment
Share on other sites

The first thing I would look at is what other contributions you have installed. I've found that many times other contributions will cause this to act up. I'm currently working on a problem where WPP is passing the wrong total to Paypal. I know why it's doing it I just haven't found the right work around yet. Anyway, Check your other contributions, one of them may be interferring with this one.

 

Yes, I considered that. I created a test site at dev2.lawatches.com and it has the same problem with a fresh install and no contributions added. Very strange. If you look at the module/payment/paypal.php file you'll see that the 'item name' is set to company name, so that is what is being passed to paypal. Should be product name or cart contents or something. I just don't know what the variable is.

 

The following is a workaround, but its incomplete:

http://www.oscommerce.com/forums/index.php?showtopic=233624

 

Still looking for some who can say why the paypal.php file is written to post the company name.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...