Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Checjout not displaying


ddaanniieelluk

Recommended Posts

I've got it installed, and can add products etc., but when i click on checkout it just displays a blank page saying 'this page cannot be displayed'. Nor can i log in or create an account. ANy help with this would be much appreciated.

Link to comment
Share on other sites

I've got it installed, and can add products etc., but when i click on checkout it just displays a blank page saying 'this page cannot be displayed'. Nor can i log in or create an account. ANy help with this would be much appreciated.

 

Check your config file particularly these two lines

 

define('HTTPS_SERVER', 'https://domain.com'); // eg, https://localhost - should not be empty for productive servers

define('ENABLE_SSL', true); // secure webserver for checkout procedure?

 

If you have SSL installed the config should be as above

otherwise it should be as below

define('HTTPS_SERVER', 'http://domain.com'); // eg, https://localhost - should not be empty for productive servers

define('ENABLE_SSL', false); // secure webserver for checkout procedure?

Link to comment
Share on other sites

Check your config file particularly these two lines

 

define('HTTPS_SERVER', 'https://domain.com'); // eg, https://localhost - should not be empty for productive servers

define('ENABLE_SSL', true); // secure webserver for checkout procedure?

 

If you have SSL installed the config should be as above

otherwise it should be as below

define('HTTPS_SERVER', 'http://domain.com'); // eg, https://localhost - should not be empty for productive servers

define('ENABLE_SSL', false); // secure webserver for checkout procedure?

 

Hi, I'm also experiencing exactly the same problem. Checked my config & everything is in order. Any other ideas?

Link to comment
Share on other sites

New problem, now cannot even add a product to cart. See following error :

 

Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /home/jenny80/public_html/jenzdesign/shop/includes/configure.php:49) in /home/jenny80/public_html/jenzdesign/shop/includes/functions/sessions.php on line 97

 

Warning: Cannot modify header information - headers already sent by (output started at /home/jenny80/public_html/jenzdesign/shop/includes/configure.php:49) in /home/jenny80/public_html/jenzdesign/shop/includes/functions/general.php on line 33

 

 

HELP?!

Link to comment
Share on other sites

New problem, now cannot even add a product to cart. See following error :

 

Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /home/jenny80/public_html/jenzdesign/shop/includes/configure.php:49) in /home/jenny80/public_html/jenzdesign/shop/includes/functions/sessions.php on line 97

 

Warning: Cannot modify header information - headers already sent by (output started at /home/jenny80/public_html/jenzdesign/shop/includes/configure.php:49) in /home/jenny80/public_html/jenzdesign/shop/includes/functions/general.php on line 33

HELP?!

 

 

This usually happens when you edit the via cpanel file manager, use a text editor

remove any spaces after the last line in the configure.php

 

see if it works?

Link to comment
Share on other sites

This usually happens when you edit the via cpanel file manager, use a text editor

remove any spaces after the last line in the configure.php

 

see if it works?

 

 

OH ... it worked wonderfully.. Thanks..

 

But still trying to sort out the shared SSL issue with my website :(

Link to comment
Share on other sites

What url does it show when you checkout

 

Using a shared SSL, in fact my host juz resolved it for me.

 

But now I have another problem, the following problem showed after I added a new PHP page & updated filenames.php and english.php files :

 

Fatal error: Cannot redeclare tep_db_connect() (previously declared in /home/jenny80/public_html/jenzdesign/shop/includes/functions/database.php:13) in /home/jenny80/public_html/jenzdesign/shop/includes/functions/database.php on line 13

 

:(

Link to comment
Share on other sites

Check your config file particularly these two lines

 

define('HTTPS_SERVER', 'https://domain.com'); // eg, https://localhost - should not be empty for productive servers

define('ENABLE_SSL', true); // secure webserver for checkout procedure?

 

If you have SSL installed the config should be as above

otherwise it should be as below

define('HTTPS_SERVER', 'http://domain.com'); // eg, https://localhost - should not be empty for productive servers

define('ENABLE_SSL', false); // secure webserver for checkout procedure?

 

Your a genius! Thanks so much. I really do appreciate your help.

 

Dan

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...