Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Not receiving emails for order by users or admin


Dmacman

Recommended Posts

Hi All,

 

I setup osCommerce and added the email factory fix for SMTP mail authentication...

 

In any case, you will need to and update the email addresses

and host setting, and turn authentication on if necessary...

 

if (EMAIL_TRANSPORT == 'smtp') {

 

include_once("Mail.php");

 

$headers["From"] = $from;

$headers["To"] = $to_addr;

$headers["Subject"] = $subject;

$headers["Bcc"] = "[email protected]"; //<---- I put my admin email address here.

$params["host"] = "yourdomain.com"; //<--- I put our mail.domain.org address here.

$params["port"] = "25";

$params["auth"] = false; //<-- I made this true, since we use SMTP authentication required

$params["username"] = "user"; //<--- I put system admin username here (from the php.ini configuration).

$params["password"] = "password"; //<--- I put the system admin password here (from the php.ini configuration).

 

// Create the mail object using the Mail::factory method

$mail_object =& Mail::factory("smtp", $params);

return $mail_object->send("$to_addr, [email protected]", $headers, $this->output);

}

}

 

But when I place an order as a 'customer' (which I used a different email address than my "admin" email address) and I do not receive a comfirmation of the order, as the customer, or as the admin? I don't even get a failure notice, since I am the system admin????

Anyone seen this before?

 

Thanks in advance,

Don

Link to comment
Share on other sites

Ok, I finally got the email working by going to another site we have, hosted by an ISP that provides osCommerce as an install, and replacing my email.php and class.smtp.php files.

 

But now I am trying to solve a small issue. The order and confirmation emails are one continous line of text, the CRLF translations (I am on a windows machine) are not working.

I read a few posts suggesting going thru the email.php and class.smtp.php and replacing all instances of \r\n or

\r or \n with <br> but that had no effect.

 

Under the admin setup in "E-Mail Options" I have is set as "E-Mail Linefeeds CRLF" but that has no effect also.

 

Anyone seen this before?

 

Thanks in Advance,

Don

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...