Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

weird admin area issue


cxixer

Recommended Posts

OK, when you click 'orders', the customer info shows up fine. When you click 'customers', most of the information is blank, it's like it can't pull up the info from the database. I only checked 5 or so different customers, but one of them the info does show up fine, the rest are blank. It gives the following error.

 

 

Warning: reset(): Passed variable is not an array or object in /shop/admin/includes/classes/object_info.php on line 17

 

Warning: Variable passed to each() is not an array or object in /shop/admin/includes/classes/object_info.php on line 18

 

 

Another thing, I have a test account that I use to periodically check out updates or changes I make to the store. This test account, when I was checking out on the delivery info page, didn't show the info for the billing account, it just had a comma. Then gave an error on the following page (payment info), as follows:

 

Warning: htmlspecialchars() expects parameter 1 to be string, array given in /shop/includes/functions/general.php on line 42

 

Warning: htmlspecialchars() expects parameter 1 to be string, array given in /shop/includes/functions/general.php on line 42

 

I did just install a contrib, the discount coupons one. I can not figure out what is wrong, any help is appreciated!

Link to comment
Share on other sites

OK, if the customer goes to "change address", they can select their current address from the stored addressbook, or type in a new one. They have to do this with both shipping and billing, but if they do the order will go through perfectly.

 

 

How do I get it so the addresses will be filled in automatically? If they do not do this they get an error!

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...