Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

What is the PERMISSIONS command? Where's it go?


zzorks

Recommended Posts

:'( I'm installing osCommerce, but I get to this point and the installation fails, it's telling me:

 

The configuration files do not exist, or permission levels are not set.

 

Please perform the following actions:

cd /var/www/vhosts/zzorks.org/httpdocs/catalog/includes/

touch configure.php

chmod 706 configure.php

cd /var/www/vhosts/zzorks.org/httpdocs/catalog/admin/includes/

touch configure.php

chmod 706 configure.php

 

I've created these files and inserted them in httpdocs/catalog/includes/configure.php, using 706 or 777 and the message stays and I can't continue.

 

Here's the files I've tried:

 

chmod 706 configure.php

chmod 706 configuration.php

chmod $catalog, $706

chmod $admin, $706

 

I tried the first two, together, and used 706, but it didn't work, I tried 777 and it didn't work.

I tried the last two, together, and used 777 and 706 and it didn't work.

I tried all four together, using 777 and they didn't work.

 

I inserted the command as listed in the file httdocs/catalog/includes/configure.php and also in the file httpdocs/catalog/admin/includes/configuration.php but it's not working for me?

 

:blink: Does anyone know what is (are) the correct command (s) and where they should be installed?

 

Thanks for your help,

 

Best regards,

 

Manny

Link to comment
Share on other sites

The file should contain

<?php
chmod('catalog/includes/configure.php', 0444); 
?>

Place it in your root to run it.

 

Jack

Support Links:

For Hire: Contact me for anything you need help with for your shop: upgrading, hosting, repairs, code written, etc.

All of My Addons

Get the latest versions of my addons

Recommended SEO Addons

Link to comment
Share on other sites

:lol:

Ok-I did it, I Got past the "PERMISSIONS-chmod-Configuration files do not exist issue"

 

Here's what I did to get past the "Configuration files do not exist, or

permission levels are not set" scenario:

 

I used Bill110's contribution:

 

"navigate to the file and right click, set as read only.(assuming this is the

configure.php file we are talking about....and do like I do use FTP.

Right click on file and select chmod."

 

and I combined that with Vger's contribution:

 

"To 'chmod' the file using another file, do this:Create a new text document on your

desktop and rename it to chmod.php.

Put this code in it:CODE<?phpchmod ("includes/configure.php", 0444);?>Upload it to

the root of your website and go to it in a browser

e.g. http://www.yourdomain.com/chmod.php - you won't see anything but it shuld change

the permissions. Delete the 'chmod' file after using.Vger"

 

and also another contribution by Vger:

 

"On a Windows box the correct permissions for configure.php files is probably 644.

Trying to change them via FTP won't work, bcause the CHMOD function is specific to Apache

servers - so you'll need to use the File Manager in your web hosting control panel

(Plesk, cPanel, Ensim) to change the permissions.Vger"

 

I applied both of these and the installation continued without a hitch, very well done Vger!!

Hats off to you!

 

NO ENTRIES WERE MADE IN THE configure.php or configuration.php files, I DELETED THE PREVIOUS

entries I had made.

 

:thumbsup: Thanks for the great support everyone. Lotta knowleageable people in this forum.

 

Best regards,

 

Manny

Link to comment
Share on other sites

Part of the reason I like a Mac platform! It's just like Linux for dummies ;)

 

I can even access my LAMP server via FTP (well, as of last weekend after spending a day getting the new machine working ahahah)

 

Rob

Rob Bell - Inspired Graphix

Customising osCommerce in Australia, and the world!

View my profile for web and email links.

 

I'm sorry, but i cannot offer Free support via PM etc, and osCommerce forums prohibit me from putting any reference to paid support in my signauture.

However viewing my profile may provide links to my website or something like that which you may find useful.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...