Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

I can't finalize orders "Merchant username or password is not valid or merchant account is not active."


bhomis

Recommended Posts

Hi. I've had osCommerce running for a year, and suddenly I get this message when finalizing an order:

"Merchant username or password is not valid or merchant account is not active."

I haven't changed anything, and now I suddenly get this.

I've called tech support for my hosting company and credit card processing company, and they're both pointing their fingers towards osCommerce as being the problem.

I really need help with this. Please.

Thank you.

Bruce

Link to comment
Share on other sites

Hi. I've had osCommerce running for a year, and suddenly I get this message when finalizing an order:

"Merchant username or password is not valid or merchant account is not active."

I haven't changed anything, and now I suddenly get this.

I've called tech support for my hosting company and credit card processing company, and they're both pointing their fingers towards osCommerce as being the problem.

I really need help with this. Please.

Thank you.

Bruce

 

Just to let you know I have had the same problem in the past two weeks. My merchant gateway did an upgrade and my credit cards are processing some of the time. On the other hand customers are telling me that when they want to confirm the order it wont confirm. I am sure we may be having the same problems.

 

Pink

Link to comment
Share on other sites

Okay. Here's what I'm noticing.

When I first click "confirm order", I get that error. If I click the back button, the info is still there and I click "confirm order" again - presto - it works.

So I checked the code for:

https://www.mysite.com/catalog/checkout_con...605f9b6d4c063f9

When I look at the code for this page before clicking "confirm order", there are no input parameters for the form named "checkout_confirmation". I click "confirm order", and get the error message.

Now after I get the error message I click the back button and the info is still there. Before clicking "confirm order", I look at the code for the above page, AND THE INPUT PARAMETERS ARE ALL THERE. I click "confirm order" and it works.

So now the question is "why are the input parameters not always being included on that above page?"

Please help.

Thank you.

Bruce

Link to comment
Share on other sites

If you haven't altered osCommerce and your payment processing was working fine previously then the problem is either with your hosting company (did they upgrade PHP or MySQL?) or with your payment processing company.

 

Vger

Link to comment
Share on other sites

If you haven't altered osCommerce and your payment processing was working fine previously then the problem is either with your hosting company (did they upgrade PHP or MySQL?) or with your payment processing company.

 

Vger

 

I haven't altered anything and after an hour on the phone with my hosting company, they say they haven't changed anything either. My payment processing company says that nothing has changed either.

I have no clue...

My SSL was renewed last month. Could that have anything to do with it?

Thank you.

Bruce

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...