Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

PLEASE HELP - I CAN'T ACCESS MY ADMIN PAGES


murphy779

Recommended Posts

I was changing the http to https and I changed part of the code and now I get the following error:

 

Parse error: syntax error, unexpected T_STRING in /home/newag5/public_html/admin/includes/configure.php on line 16

 

I can't get in any of the files of my website now. The website is still there, but I can't get in. Please help.

 

I read the how to change the config files when you purchase an ssl certificate, but my codes were different. There was a lot more code than shown in the example.

Link to comment
Share on other sites

My first thought is....you shouldn't have to change anything in that file from http to https

 

You simply change the word FALSE to TRUE for the line in that file which begins with HTTPS, now that you have a SSL cert installed.

 

For example, my file in catalog/admin/includes/configure.php reads like this:

 

// Define the webserver and path parameters

// * DIR_FS_* = Filesystem directories (local/physical)

// * DIR_WS_* = Webserver directories (virtual/URL)

define('HTTP_SERVER', 'http://www.nameofmysite.com'); // eg, http://localhost - should not be empty for productive servers

define('HTTP_CATALOG_SERVER', 'http://www.nameofmysite.com');

define('HTTPS_CATALOG_SERVER', 'https://www.nameofmysite.com');

define('ENABLE_SSL_CATALOG', 'true'); // secure webserver for catalog module

 

That last line....ENABLE_SSL_CATALOG initially read 'false' and I simply had to change it to true, once I installed my SSL cert.

 

You need change nothing else. You're not to change any calls from HTTP to HTTPS. You are only to change that line I referenced from 'false' to 'true'.

Link to comment
Share on other sites

My first thought is....you shouldn't have to change anything in that file from http to https

 

You simply change the word FALSE to TRUE for the line in that file which begins with HTTPS, now that you have a SSL cert installed.

 

For example, my file in catalog/admin/includes/configure.php reads like this:

 

// Define the webserver and path parameters

// * DIR_FS_* = Filesystem directories (local/physical)

// * DIR_WS_* = Webserver directories (virtual/URL)

define('HTTP_SERVER', 'http://www.nameofmysite.com'); // eg, http://localhost - should not be empty for productive servers

define('HTTP_CATALOG_SERVER', 'http://www.nameofmysite.com');

define('HTTPS_CATALOG_SERVER', 'https://www.nameofmysite.com');

define('ENABLE_SSL_CATALOG', 'true'); // secure webserver for catalog module

 

That last line....ENABLE_SSL_CATALOG initially read 'false' and I simply had to change it to true, once I installed my SSL cert.

 

You need change nothing else. You're not to change any calls from HTTP to HTTPS. You are only to change that line I referenced from 'false' to 'true'.

 

The instructions that I was given from this web site and from my host (who I bought the ssl certificate from and they installed it) said to change all the addresses from http to http and to change from false to true. I know what I did wrong now, but the mistake I made has caused me to not be able to get to any of my files in my web site. Do you know how I can get back in the file to fix my mistake? Thank you for responding - I really appreciate it. I did not realize this was going to be such a tricky thing to figure out. Thank you again.

Link to comment
Share on other sites

if you have an FTP client you can use that to download the admin/includes/configure.php file, then change it using notepad or wordpad and then upload it to overwrite the file thats there.

 

Or if you go to your hosts website most of them have a C-panel, you can go there log in, go to file manager usually in the file manager you have an edit option it will open a new screen allow you to edit the file and save it.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...