Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

After SSL install, Checkout payment got error


smithveg

Recommended Posts

Hello,

 

Before i install SSL, I can receive the email notification from my site(order notification), payment gateway.

 

I had installed SSL, it can go throught all the checkout process, until payment gateway.

In payment gateway, it still can proceed nicely. In the last step which is 'Payment Success'.

 

A message, 'Please click here to notify our supplier that your order was successful'

Then i click 'Click Here To Finaliza Your Order'

 

After i click it will link back to 'checkout_payment.php page' and prompt a red line error below the header image as this, 'There has been an error processing your credit card. Please try again'.

 

I still can receive the mail from 2Checkout payment gateway, to tell me you have an order. But i can not receive any email notification from my site. In addition, i see the error. Can someone helps me...

 

You helps would be appreciated, thank...

 

smith

****

Hello World! ^.^ I'm a Internet naive. Browse my working profile

Malaysia Web Services - OPerion Website Marketing System

Link to comment
Share on other sites

Hi Smith ...

 

I think the error lies in your includes/classes/cc_validation .... check out this post. Perhaps it'll help: http://www.oscommerce.com/forums/lofiversion/i...hp/t141519.html

Jason

 

Simple 1-2-3 Intructions on how to get, install and configure SSL

 

The Google Sandbox explained

 

Simple to follow instructions on how to change the look of your OSC

 

How To Make A Horrible OSC Website

 

my toolbox: All things WordPress-related - All things Adobe-related - PHP Designer 2007 - Codecanyon Junkie - Crimson Editor - Winmerge - phpMyAdmin - WS_FTP

 

my installed contributions: Category Banners, File Upload feature-.77, Header Tags, Sort_Product_Attributes_1, XSellv2.3, Price Break 1.11.2, wishlist 3.5, rollover_category_images_v1.2, Short_Description_v2.1, UPSXML_v1_2_3, quickbooks qbi_v2_10, allprods v4.4, Mouseover-effect for image-buttons 1.0, Ultimate_SEO, AAP 1.41, Auto Select State Value, Fast Easy Checkout, Dynamic SiteMap v2.0, Image Magic, Links Manager 1.14, Featured Products, Customer Testimonials, Article Manager, FAQ System, and I'm sure more ...

Link to comment
Share on other sites

I think the error lies in your includes/classes/cc_validation .... check out this post. Perhaps it'll help: http://www.oscommerce.com/forums/lofiversion/i...hp/t141519.html

 

Do you think is the site problem? I honestly tell you. I had taken out all the credit card input form. You can have a look in my site www.mypewter.com and try to register an account and process the checkout. You will noticed that you no need to keyin any CC information. In my view point, that's a trouble because a buyer need to keyin their CC information in my site, AND 2checkout.com site.

 

Ok.

 

Before i had install the SSL in my site. Everything went well.

If a customer make an order, we(merchant) can receive the notification from my site, and 2checkout.com. Then the customer can go back to my site from 2checkout.com nicelyt without any error.

 

After i have install the SSL. It something wrong.

PROBLEM, When a customer success to make a payment. He will link back to my site. But it will link back to 'payment information' page. And prompt me the CC error. But he already make a payment into my 2checkout.com account.

 

Is that anything i need to set in 2checkout.com, or change from http to https

since i have install SSL.

 

I had attach two print screen here, 8.jpeg and 9.jpeg

In 8.jpeg, it tell you an payment was success now you can link back to the site.

In 9.jpeg, ERROR.... It should not come back to this page, right?

 

8he6.th.jpg

9mv5.th.jpg

 

Hope my problems can make sense.

Thanks.

****

Hello World! ^.^ I'm a Internet naive. Browse my working profile

Malaysia Web Services - OPerion Website Marketing System

Link to comment
Share on other sites

Mr. Jason Weber,

 

I had ask this question to the 2checkout payment services. And they give me a reply as below. Again, i'm not really understand how to resolve this issue. And i hope the information that i given could you helps you understand more in it. Thank.

 

As a final note I noticed that you were using OS Commerce as the shopping cart for your site. Inside of our documentation there is a piece of text which may be the reason you are getting these odd results with the SSL.

 

"There is also a known issue that OSCommerce has alerted us of. The OSCommerce cart requires 'Force Cookie Use' set to ON. This means that web Sites using a shared-SSL cert will not work. Most problems with the OSCommerce contribution are due to cookies not being set up properly and there unfortunately is not a work around for this."

****

Hello World! ^.^ I'm a Internet naive. Browse my working profile

Malaysia Web Services - OPerion Website Marketing System

Link to comment
Share on other sites

They are wrong. You should try downloading and installing this module, which is specifically designed for 2checkout: http://www.oscommerce.com/community/contributions,904

Jason

 

Simple 1-2-3 Intructions on how to get, install and configure SSL

 

The Google Sandbox explained

 

Simple to follow instructions on how to change the look of your OSC

 

How To Make A Horrible OSC Website

 

my toolbox: All things WordPress-related - All things Adobe-related - PHP Designer 2007 - Codecanyon Junkie - Crimson Editor - Winmerge - phpMyAdmin - WS_FTP

 

my installed contributions: Category Banners, File Upload feature-.77, Header Tags, Sort_Product_Attributes_1, XSellv2.3, Price Break 1.11.2, wishlist 3.5, rollover_category_images_v1.2, Short_Description_v2.1, UPSXML_v1_2_3, quickbooks qbi_v2_10, allprods v4.4, Mouseover-effect for image-buttons 1.0, Ultimate_SEO, AAP 1.41, Auto Select State Value, Fast Easy Checkout, Dynamic SiteMap v2.0, Image Magic, Links Manager 1.14, Featured Products, Customer Testimonials, Article Manager, FAQ System, and I'm sure more ...

Link to comment
Share on other sites

Mr. jpweber,

 

May i ask you about the 2checkout demo testing?

 

I still remember last few months ago. I can do the demo purchase until the payment success in 2checout and link back to my site. That's my mistake, i did not document properly. And from my current document, i write

 

put the <input type="hidden" name="demo" value="Y"></input> around the form.

yeah, i can find the </form> but i can not find the opening form in checkout_confirmation.php

And i had already confirm with 2checkout, they still using the code above to do a demo purchase.

But i'm not sure, why i can't trace this out. Since i had also try to put the code somewhere in checkout_confirmation.php

 

Can you show me if you know how to do that.

Thank

****

Hello World! ^.^ I'm a Internet naive. Browse my working profile

Malaysia Web Services - OPerion Website Marketing System

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...