Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Cookie Usage when adding to cart


rui83

Recommended Posts

Hello :),

 

Sorry for having to post a help question as my first post, but I just installed OsCommerce, and whenever I try to add something to the cart, it tells me that I must enable cookies. I've tried it in both IE and FF, as well as changing the security settings. I've also tried to see if there was a resolution in here before, but can't seem to find it.

 

I would greatly appreciate the help!

 

Thanks in advance,

Rui :)

Link to comment
Share on other sites

Hello :),

 

Sorry for having to post a help question as my first post, but I just installed OsCommerce, and whenever I try to add something to the cart, it tells me that I must enable cookies. I've tried it in both IE and FF, as well as changing the security settings. I've also tried to see if there was a resolution in here before, but can't seem to find it.

 

I would greatly appreciate the help!

 

Thanks in advance,

Rui :)

 

I forgot to add the link to the site: www.monteverdeproducts.com/index.php

 

I would appreciate any help :blush:

Link to comment
Share on other sites

I'm in exactly the same situation. Even when cookie blocking is turned completely off. I even tried with my firewall/internet security turned off.

 

Hopefully this is an easy one to solve, please post a solution if you find one. I'll do the same. :)

Link to comment
Share on other sites

First place to look at:

admin -> Configuration -> Sessions -> force cookie use -> FALSE

 

Ken

commercial support - unProtected channel, not to be confused with the forum with same name - open to everyone who need some professional help: either PM/email me, or go to my website (URL can be found in my profile).

over 20 years of computer programming experience.

Link to comment
Share on other sites

I forgot to add the link to the site: www.monteverdeproducts.com/index.php

 

I would appreciate any help :blush:

 

I would suggest your cookie settings are wrong:

 

osCsid=96352aa6e9fc45bb00a18f89ad2fb1ca; path=/cgi; domain=www.monteverdeproducts.com

 

specifically your cookie path setting.

Treasurer MFC

Link to comment
Share on other sites

Just an update - I've solved my problems too: I've got force cookies to false, but I also had my SSL configuration wrong in my configure.php file.

 

I'm using shared SSL with Netfirms so I had to change:

 

  define('HTTP_SERVER', 'http://my_domain.com'); 
 define('HTTPS_SERVER', 'https://my_domain.com');  
 define('ENABLE_SSL', true); 
 define('HTTP_COOKIE_DOMAIN', 'my_domain.com');
 define('HTTPS_COOKIE_DOMAIN', 'my_domain.com');

 

to

 

	define('HTTP_SERVER', 'http://my_domain.com'); 
define('HTTPS_SERVER', 'https://my_domain.com.sslpowered.com');  
define('ENABLE_SSL', true); 
define('HTTP_COOKIE_DOMAIN', 'my_domain.com');
define('HTTPS_COOKIE_DOMAIN', 'my_domain.com.sslpowered.com');

 

This seems obvious now, but I guess I missed it in the setup. Thanks for the other pointers. Hopefully this helps others.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...