Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Getting a php error on clean install


Cowboy_one_one

Recommended Posts

Hello,

I'm getting the error "register_globals is disabled in php.ini please inable it".

So since i'm running xampp I went on over to my xampp/php dir and first ; ed out every Register_globals=OFF I could find in php.ini, php4.ini, php5.ini, and for all my trouble I got the same message...

So could someone please tell me what to do.

Thank you,

Chris Cain

Link to comment
Share on other sites

Hello,

I'm getting the error "register_globals is disabled in php.ini please inable it".

So since i'm running xampp I went on over to my xampp/php dir and first ; ed out every Register_globals=OFF I could find in php.ini, php4.ini, php5.ini, and for all my trouble I got the same message...

So could someone please tell me what to do.

Thank you,

Chris Cain

 

Ah.. rem'ing it out might not fix it though, as the default is 'Off' for recent php releases. I think you'll need to set it explicitly to 'On'.

 

Or take a look at the 'register globals' contribution that means that you can leave them 'Off' in the ini.

Link to comment
Share on other sites

As this is a local installation (Intranet) then search for all files called php.ini and edit them all. After that shut down your computer and reboot.

 

Vger

FATAL ERROR: register_globals is disabled in php.ini, please enable it! it didn't work... ok so,

If anyone knows the file structure of xampp, Then I set register_globals to Register_Globals=ON in,

php.ini, php5.ini, dir/php4 php4.ini but I still get the same error... :'(

Link to comment
Share on other sites

FATAL ERROR: register_globals is disabled in php.ini, please enable it! it didn't work... ok so,

If anyone knows the file structure of xampp, Then I set register_globals to Register_Globals=ON in,

php.ini, php5.ini, dir/php4 php4.ini but I still get the same error... :'(

 

what about creating a php.ini file and putting it into your root and admin directory with the value

 

register_globals = on;

Regards

 

Mark A Reynolds

Link to comment
Share on other sites

Just to be shure i'm editing the right part...

 

; You should do your best to write your scripts so that they do not require

; register_globals to be on; Using form variables as globals can easily lead

; to possible security problems, if the code is not very well thought of.

register_globals = ON

 

This is how I did it in php.ini, php5.ini, dir/php4 php4.ini.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...