Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

SSL problem - should be basic


vichon

Recommended Posts

I have installed a self signed cert for a test site while I learn OSC. The cert loads fine for both the catalog and the admin sections. However, when I click on a link for either section, it goes to an http page.

Here is my includes/configure.php

 

<?php

/*

osCommerce, Open Source E-Commerce Solutions

http://www.oscommerce.com

 

Copyright © 2003 osCommerce

 

Released under the GNU General Public License

*/

 

// Define the webserver and path parameters

// * DIR_FS_* = Filesystem directories (local/physical)

// * DIR_WS_* = Webserver directories (virtual/URL)

define('HTTP_SERVER', 'http://alextechstore.com'); // eg, http://localhost - should not be empty for productive servers

define('HTTPS_SERVER', 'https://alextechstore.com'); // eg, https://localhost - should not be empty for productive servers

define('ENABLE_SSL', true); // secure webserver for checkout procedure?

define('HTTP_COOKIE_DOMAIN', 'alextechstore.com');

define('HTTPS_COOKIE_DOMAIN', 'alextechstore.com');

define('HTTP_COOKIE_PATH', '/catalog/');

define('HTTPS_COOKIE_PATH', '/catalog/');

define('DIR_WS_HTTP_CATALOG', '/catalog/');

define('DIR_WS_HTTPS_CATALOG', '/catalog/');

define('DIR_WS_IMAGES', 'images/');

define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

define('DIR_WS_INCLUDES', 'includes/');

define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

 

define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');

define('DIR_FS_CATALOG', '/var/oscommerce/catalog/');

define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');

define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');

 

// define our database connection

define('DB_SERVER', 'localhost'); // eg, localhost - should not be empty for productive servers

define('DB_SERVER_USERNAME', 'alext');

define('DB_SERVER_PASSWORD', 'trbn21');

define('DB_DATABASE', 'oscalexstore');

define('USE_PCONNECT', 'false'); // use persistent connections?

define('STORE_SESSIONS', ''); // leave empty '' for default handler or set to 'mysql'

?>

 

 

Here is my httpd.includes (Im using virtual hosts)

<VirtualHost 192.168.21.4:80>

ServerName alextechstore.com:80

DocumentRoot /home/httpd/vhosts/alextechstore.com/httpdocs

CustomLog /home/httpd/vhosts/alextechstore.com/var/log/access_log combined

ErrorLog /home/httpd/vhosts/alextechstore.com/var/log/error_log

<IfModule mod_userdir.c>

UserDir /home/httpd/vhosts/alextechstore.com/web_users

</IfModule>

ScriptAlias /cgi-bin/ /home/httpd/vhosts/alextechstore.com/cgi-bin/

<IfModule mod_ssl.c>

SSLEngine off

</IfModule>

<Directory /home/httpd/vhosts/alextechstore.com/httpdocs>

Options -Indexes

<IfModule sapi_apache2.c>

php_admin_flag engine on

php_admin_value open_basedir "/home/httpd/vhosts/alextechstore.com"

php_admin_value upload_tmp_dir "/home/httpd/vhosts/alextechstore.com/tmp"

php_admin_value session.save_path "/home/httpd/vhosts/alextechstore.com/tmp"

</IfModule>

Options +Includes +ExecCGI

<IfModule mod_perl.c>

<Files ~ (\.pl)>

SetHandler perl-script

PerlHandler ModPerl::Registry

allow from all

PerlSendHeader On

</Files>

</IfModule>

</Directory>

<Directory /home/httpd/vhosts/alextechstore.com/httpdocs/catalog/admin/>

#Allowoverride All

AuthType Basic

AuthName "Alextechstore.com"

AuthUserFile /home/httpd/vhosts/alextechstore.com/httpdocs/.htpasswd

Require user webadmin

</Directory>

</VirtualHost>

<VirtualHost 192.168.21.4:443>

ServerName alextechstore.com:443

DocumentRoot /home/httpd/vhosts/alextechstore.com/httpdocs

CustomLog /home/httpd/vhosts/alextechstore.com/var/log/access_log combined

ErrorLog /home/httpd/vhosts/alextechstore.com/var/log/error_log

<IfModule mod_userdir.c>

UserDir /home/httpd/vhosts/alextechstore.com/web_users

</IfModule>

ScriptAlias /cgi-bin/ /home/httpd/vhosts/alextechstore.com/cgi-bin/

<IfModule mod_ssl.c>

SSLEngine On

SSLCertificateFile /etc/racoon/certs/alextechstore.com.cert

SSLCertificateKeyFile /etc/racoon/private/alextechstore.com.key

</IfModule>

<Directory /home/httpd/vhosts/alextechstore.com/httpdocs>

Options -Indexes

<IfModule sapi_apache2.c>

php_admin_flag engine on

php_admin_value open_basedir "/home/httpd/vhosts/alextechstore.com"

php_admin_value upload_tmp_dir "/home/httpd/vhosts/alextechstore.com/tmp"

php_admin_value session.save_path "/home/httpd/vhosts/alextechstore.com/tmp"

</IfModule>

Options +Includes +ExecCGI

<IfModule mod_perl.c>

<Files ~ (\.pl)>

SetHandler perl-script

PerlHandler ModPerl::Registry

allow from all

PerlSendHeader On

</Files>

</IfModule>

</Directory>

<Directory /home/httpd/vhosts/alextechstore.com/httpdocs/catalog/admin/>

#Allowoverride All

AuthType Basic

AuthName "Alextechstore.com"

AuthUserFile intentionally blank

Require user webadmin

</Directory>

</VirtualHost>

 

 

Thoughts how to fix?

Link to comment
Share on other sites

You have DB user name and password

Please take asterik it out

chris

 

// define our database connection

define('DB_SERVER', 'localhost'); // eg, localhost - should not be empty for productive servers

define('DB_SERVER_USERNAME', '*****');

define('DB_SERVER_PASSWORD', '******');

define('DB_DATABASE', '********');

define('USE_PCONNECT', 'false'); // use persistent connections?

define('STORE_SESSIONS', ''); // leave empty '' for default handler or set to 'mysql'

?>

 

Your edit post has already timed out so I would contact a mod to delete this post but first of all CHANGE YOUR DATABASE PASSWORD AND USERNAME! FAST

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...