Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

register_globals is disabled in php.ini, please enable it!


Wanwan

Recommended Posts

You will either need to install the register globals contribution or upload a file named php.ini with register_globals=on in it. The file will have to go into your root and probably your admin.

 

Jack

Support Links:

For Hire: Contact me for anything you need help with for your shop: upgrading, hosting, repairs, code written, etc.

All of My Addons

Get the latest versions of my addons

Recommended SEO Addons

Link to comment
Share on other sites

You will either need to install the register globals contribution or upload a file named php.ini with register_globals=on in it. The file will have to go into your root and probably your admin.

 

Jack

 

Anything else needs to be on that file? any special tags or anything?

as you can tell, I'm a newbee and just started exploring.

 

Thanks,

Link to comment
Share on other sites

Anything else needs to be on that file? any special tags or anything?

as you can tell, I'm a newbee and just started exploring.

 

Thanks,

 

that's all you need, nothing else,

just be sure to copy this file to root of ur shop, admin, includes and install directories,

Link to comment
Share on other sites

what I did was,

 

1) goto the start menu and search php.ini files

2) all the php.ini will appear

3) edit most of the php.ini

from register_globals = Off to register_globals = On

 

That is how I did it.

Wanwan -- %_%_

Link to comment
Share on other sites

what I did was,

 

1) goto the start menu and search php.ini files

2) all the php.ini will appear

3) edit most of the php.ini

from register_globals = Off to register_globals = On

 

That is how I did it.

 

Unable to find php.ini on my computer. Do I need to create this file with one line called "register_globals = On"?

Link to comment
Share on other sites

Unable to find php.ini on my computer. Do I need to create this file with one line called "register_globals = On"?

 

Are you hosting the site on your computer?

You would only look for the file on your computer is hosting the site.

Backup before making changes. Backup before making changes! Backup before making changes!!

 

You did do a backup? eh?

Link to comment
Share on other sites

Are you hosting the site on your computer?

You would only look for the file on your computer is hosting the site.

 

No, I'm not hosting the site on my computer. This php.ini file does not show up on the hosting server. I'm receiving this error message: register_globals is disabled in php.ini, please enable it.

 

Not sure what to do next. My php programming skills are limited.

Link to comment
Share on other sites

- Open a text editor, like notepad.

- type in register_globals=on

- save the file with the name of php.ini (your editor may append a .txt to it. If so, rename the file to php.ini)

- upload the file to your shops rooto directory and admin directory.

 

Jack

Support Links:

For Hire: Contact me for anything you need help with for your shop: upgrading, hosting, repairs, code written, etc.

All of My Addons

Get the latest versions of my addons

Recommended SEO Addons

Link to comment
Share on other sites

i have the same problem. i've tryed editing both the .htaccess file as well as create the php.ini wiht register_globals=on i am still getting the fatal error message when trying to install the software. i am starting to wonder if this is another issue with using godaddy.com :pissed:

Link to comment
Share on other sites

- Open a text editor, like notepad.

- type in register_globals=on

- save the file with the name of php.ini (your editor may append a .txt to it. If so, rename the file to php.ini)

- upload the file to your shops rooto directory and admin directory.

 

Jack

 

 

Thanks Jack, I will create that file and upload tonight. I will let you know how it turns out.

Link to comment
Share on other sites

i just came over the same issue

you'll find a solution in osC Knowledge Base

Go to your .htaccess file in your root directory, uncomment the string that encompasses "register_globals 1"

 

I tried that approach, without success.

Link to comment
Share on other sites

Thanks Jack, I will create that file and upload tonight. I will let you know how it turns out.

 

Jack - That worked. Thank you. Now I have troubleshoot a problem with the configuration file in the Includes directory. 644 will not work and I can't set the file to 444.

Link to comment
Share on other sites

You may have to contact your host to see how to do that. Some hosts won't allow the permissions to be changed by normal methods.

 

Jack

Support Links:

For Hire: Contact me for anything you need help with for your shop: upgrading, hosting, repairs, code written, etc.

All of My Addons

Get the latest versions of my addons

Recommended SEO Addons

Link to comment
Share on other sites

Another alternative is to apply the register_globals patch contribution, and add the following lines at the top of the files:

 

$HTTP_POST_VARS = $_POST;

$HTTP_GET_VARS = $_GET;

 

 

Then the following line to /catalog/include/boxes/languages.php

 

$PHP_SELF = $_SERVER['PHP_SELF'];

 

 

(note, these lines should be added at the top of the file)

 

there may be other files that need to be patched, but this is what I've found so far....hope this helps some other people and saves some time! :)

Link to comment
Share on other sites

and...

 

$PHP_SELF = $_SERVER['PHP_SELF'];

 

to /catalog/admin/includes/application_top.php

 

(this one will fix the problem of not having the language files load - which leaves you with a bunch of unsightly CAPITALIZED_TEXT_LIKE_THIS instead of descriptions) :)

Link to comment
Share on other sites

  • 6 months later...

Oh man...i am really really pissed off...on the fresh installation my store was running fine but i had to change the look of my store...but as i installed STS v 4.5...my admin area worked fine but i am getting the following error...

 

"Server Requirement Error: register_globals is disabled in your PHP configuration. This can be enabled in your php.ini configuration file or in the .htaccess file in your catalog directory."

 

Although i have tried every way described in the previous posts...by putting php.ini in the root and admin folder and by changing the .htaccess file...but nothing worked for me...

 

I also tried the register_global patch files but nothing worked...

 

plz help me what to do as i am very new to osc...and want to change the look of my store.

 

Regards,

Farhan

Link to comment
Share on other sites

  • 8 months later...
Oh man...i am really really pissed off...on the fresh installation my store was running fine but i had to change the look of my store...but as i installed STS v 4.5...my admin area worked fine but i am getting the following error...

 

"Server Requirement Error: register_globals is disabled in your PHP configuration. This can be enabled in your php.ini configuration file or in the .htaccess file in your catalog directory."

 

Although i have tried every way described in the previous posts...by putting php.ini in the root and admin folder and by changing the .htaccess file...but nothing worked for me...

 

I also tried the register_global patch files but nothing worked...

 

plz help me what to do as i am very new to osc...and want to change the look of my store.

 

Regards,

Farhan

 

 

I am so confused. I followed the steps to make the php file and uploaded to the right directory. But nothing changed. Same error and can't log in to admin panel. I looked into the other comment of uncommenting the global_1 but I don't really know what that means or how to do it. I am just about ready to unistall and go for another shopping cart option....

Melanie Bremner

self help e books for the whole family

Link to comment
Share on other sites

  • 1 year later...

Hi! I have the same error, but i have a local server, only search in my c: disk for this file (php.ini) and found it in "program files" folder, in EasyPHP/conf_files and I search the frase "register_globals" into this file. Change his value "off" for "on". And then my page see fine.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...