Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Help Please


ladykaren

Recommended Posts

Hi everyone. I hope all is well. I have a couple of quick questions.

I've been checking things on my site and have noticed that when I

click on Write Reviews the page is not found. How can I correct this

and in what file/files?

 

Also, I've noticed that my Tell a Friend box has disappeared. I installed

this contrib http://www.oscommerce.com/community/contri...h,tell+a+friend

and followed instructions and now the box is gone. It seems the bit of code is still

in the column_right.php, but no box is showing. Has anyone else had this problem?

If so, how can I fix this.

 

Thanks as always,

Karen

Link to comment
Share on other sites

I've been checking things on my site and have noticed that when I

click on Write Reviews the page is not found. How can I correct this

and in what file/files?

 

Also, I've noticed that my Tell a Friend box has disappeared.

 

first question: either the necessary file has somehow disappeared, or the link is referring to the wrong URL, so the first step is to figure out which. when you hover over the "write reviews" link, what url is it referencing?

 

second question: Tell a Friend box has disappeared from the product_info.php page? the Tell a Friend box only appears when you are actually on a product page (product_info.php), but not a category page (index.php)

 

cheers,

rj

Link to comment
Share on other sites

first question: either the necessary file has somehow disappeared, or the link is referring to the wrong URL, so the first step is to figure out which. when you hover over the "write reviews" link, what url is it referencing?

 

second question: Tell a Friend box has disappeared from the product_info.php page? the Tell a Friend box only appears when you are actually on a product page (product_info.php), but not a category page (index.php)

 

cheers,

rj

 

Hi RJ;

Thank you very much for your reply.

 

Here is the url when I hover the Write Review

http://ladykdelights.com/cart/product_revi...products_id=618

 

I also looked through the entire product_info.php and nothing about the

Tell A Friend feature. I take it the code for this somehow went poof?

 

Thank,

Karen

Link to comment
Share on other sites

Hi RJ;

Thank you very much for your reply.

 

Here is the url when I hover the Write Review

http://ladykdelights.com/cart/product_revi...products_id=618

 

I also looked through the entire product_info.php and nothing about the

Tell A Friend feature. I take it the code for this somehow went poof?

 

Thank,

Karen

Link to comment
Share on other sites

Hi RJ;

Thank you very much for your reply.

 

Here is the url when I hover the Write Review

http://ladykdelights.com/cart/product_revi...products_id=618

 

I also looked through the entire product_info.php and nothing about the

Tell A Friend feature. I take it the code for this somehow went poof?

Any help from anyone would be most appreciated.

 

Thank,

Karen

Link to comment
Share on other sites

  • 3 weeks later...

although the Tell a Friend box only shows up on product pages (product_info.php), the code for it is not actually in product_info.php. such charming logic. it's in catalog/includes/column_right.php that it's actually called.

 

trouble shooting:

 

1. check catalog/includes/column_right.php. it should include this code:

 

 

	if (isset($HTTP_GET_VARS['products_id'])) {
  if (basename($PHP_SELF) != FILENAME_TELL_A_FRIEND) include(DIR_WS_BOXES . 'tell_a_friend.php');
  } else {
  include(DIR_WS_BOXES . 'specials.php');
}

 

the "include(DIR_WS_BOXES . 'tell_a_friend.php')" statement is what puts the Tell a Friend box in column right, and it's enclosed by the "if (isset($HTTP_GET_VARS['products_id']))" so that it only shows up when there is a specific product associated with the page

 

then check that catalog/includes/boxes/tell_a_friend.php is there and copecetic.

Link to comment
Share on other sites

Im not sure but i went to your site, and went to a product description and clicked reviews then Write review and I get page not displayed, what I am guessing is that at this point since im not logged in as a customer I should be redirected to a login screen so I tried going back to your main page and clicked on my account which would normally direct me to a login screen, I also got page not displayed. I also didnt see a Create and account link anyway. I am guessing you don't have everything setup yet because you can create an account. Your my account link should go to /cart/account.php on a secure server I take it you don't have an SSL certificate installed yet. The my account.php page would redirect you to a create or login page if you weren't already logged in.

 

This would be why the write review button doesn't work, you have to create an account or be signed in to write reviews.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...