Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Where do I set security settings ie. 777, 644 etc.


lvdan49

Recommended Posts

When I go to my shopping site I see a warning that my configuration settings are not correct and that they are vulnerable. Then I am told to set my security settings to 644. I don't know how to do this. I've never seen any place that asks for any numbers to set security. I am very very new to all of this. can someone guide me to the right tutorials or perhaps write back with instructions?

 

Thank you,

Dan

Link to comment
Share on other sites

I figured it out. Thank you jhande for your post in July:Very nice Rich, but that didn't really help as to what SHOULD be done to help the problem.Here is some info that I gathered from my hosting company, maybe it will shed some light on the subject ----------------------------------------------------------------------------Problem: Q. How do I change file permissions?Solution: A. Setting file permissions is very important in getting CGI scripts to work on your web site. Follow the below step to understand file permissions.To begin:Pages should be readable/writable by the owner and readable by the web visitor.Scripts should be readable/writable/executable by the owner and readable/executable by the web visitor.The following are abbreviations for permissions:--- (or 0) = no permissionr-- (or 4) = read-only permissionrw- (or 6) = read/write permissionr-x (or 5) = read/execute permissionrwx (or 7) = read/write/execute permissionSometimes you'll see these numbers referenced for a script. For instance, "chmod your script to "755" or "777". That means "set file permissions to "Read-Write-Execute/Read-Execute/Read-Execute". "755" is in fact the most common setting for CGI/Perl scripts - if your script does not work or you get an "Internal Server Error" when you run it try this first.To change file permissions using your FTP software:Log into your account and go to the directory where the files are located. Highlight the file that you want to change permission. Locate the "file permission" or "chmod" command on your FTP software (if you are using ws_ftp, highlight the file, right click and choose "chmod"). There should be three groups. Each group should have either checkboxes or a selection for the permission type.Set pages to rw- for the owner, no permission for the group, and r--for other.Set scripts to rwx for the owner, r-x group, and r-x for other.----------------------------------------------------------------------------As far as the image folder, mine is set to "755" and images show just fine at all my sites. Permission 755 means:7 = User - Read, Write, Execute5 = Group - Read, Execute5 = World - Read, ExecuteThe images are set to "644", all these settings are done automatically when I upload using Dreamweaver to my host.Permission 644 means:6 = User - Read, Write4 = Group - Read4 = World - ReadUser = YouIf the images are not showing with the settings set as above and you need to give the folder Group or World Write permission, then there might be something wrong with your host or your path or script calling for the images.Just my 2 cents!Good Luck :thumbsup:

 

This helped me figure out how to change my settings.

 

Dan

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...