Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

register_globals is disabled in php.ini


patc890

Recommended Posts

When I try to run http://localhost/catalog/install I get the error...

 

 

register_globals is disabled in php.ini

 

I've put phpinfo.php in place and it says that the file php.ini is in /etc

and that registers_globals =Off

 

So I've edited /etc/php.ini and changed registers_globals to On

 

phpinfo.php still reports it Off and I get the error above when I try to install?

 

Any ideas what the problem is?

 

Thanks.

 

Pat.

Link to comment
Share on other sites

When I try to run http://localhost/catalog/install I get the error...

register_globals is disabled in php.ini

 

I've put phpinfo.php in place and it says that the file php.ini is in /etc

and that registers_globals =Off

 

So I've edited /etc/php.ini and changed registers_globals to On

 

phpinfo.php still reports it Off and I get the error above when I try to install?

 

Any ideas what the problem is?

 

Thanks.

 

Pat.

I had the same problem and lookins through the different files in the server directory (I use easyphp) I found 3 different php.ini files that I edited. Finally worked

My Contributions

 

Stylesheet With Descriptions Glassy Grey Boxtops Our Products Meta Tags On The Fly

Password Protect Admin

"No matter where you go....There you are" - Buccaroo Bonsai

Link to comment
Share on other sites

If there is a php.ini file in your main localhost directory(because you have copied folders in http://localhost/catalog/), edit it and change registers_globals =Off to registers_globals =On

 

 

Thanks for the replies. I just had one php.ini and had globals "On" in it.

 

Today I went back and ran phpinfo.php again and now it's ok. So it seems

it just too a while to show up?

 

At least it works now,

 

Thanks.

Link to comment
Share on other sites

Anytime you mahe a change to the php.ini it needs to be stopped and restarted for the changes to take effect

Installed Contributions: CCGV, Close Popup, Dynamic Meta Tags, Easy Populate, Froogle Data Feeder, Google Position, Infobox Header Entire Row, Live Support for OSC, PayPal Seal with CC images, Report_m Sales, Shop by Price Revised, SQL Updater, Who's Online Enhancement, Footer, GNA EP Assistant and still going.

Link to comment
Share on other sites

You have to restart your web server before the change takes place. I'm guessing that is why it didn't work before but works now.

Please use the forums for support! I am happy to help you here, but I am unable to offer free technical support over instant messenger or e-mail.

Link to comment
Share on other sites

You have to restart your web server before the change takes place. I'm guessing that is why it didn't work before but works now.

 

 

Right I know that and I'm pretty sure I did but could be mistaken, thanks.

Link to comment
Share on other sites

Hi,

 

I don't know if you have solved this issue but there is a way around it using the .htaccess file:

 

I am running locally o WAMP 5.1 (Windows) and remotely on linux

 

I created a .htaccess file and added the flag for globals to be on, works fine, no trouble what-so-ever, just a thought!

 

Here's the code:

 

"php_flag register_globals on

Order allow,deny

Allow from all"

 

Hope this helps! cheers! :thumbsup:

Link to comment
Share on other sites

Hi,

 

I don't know if you have solved this issue but there is a way around it using the .htaccess file:

 

I am running locally o WAMP 5.1 (Windows) and remotely on linux

 

I created a .htaccess file and added the flag for globals to be on, works fine, no trouble what-so-ever, just a thought!

 

Here's the code:

 

"php_flag register_globals on

Order allow,deny

Allow from all"

 

Hope this helps! cheers! :thumbsup:

 

dont cara wat ever you use, easyphp,xampp or wat.. :) now

1.search file in your pc

2.type php.ini

3.u can see all file about php.ini (u must edit all file php.ini on your easyphp,xampp or wat)

4.open 1 by 1 that file

5.open with notepad or any editor

6.find teks!

7.type register_globals on all file you get

8.edit all register_global = off to register = on

9.u can see a lot register_global = off <--dont mistake to edit all!!!

10.save after u edit that!!

11.done!!

12.in browser type http://localhost/catalog

 

install and can see u will done..!! :) :)

 

if your browser error

1.find again n again!!!

use step 1 to 12 again to look perfect editting!!!

 

install and can see u will done..!! :) :)

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...