Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

register globals


rusty1001

Recommended Posts

Hi

 

FATAL ERROR: register_globals is disabled in php.ini, please enable it!

 

can anybody help ?

 

part of htacess file,

 

<IfModule mod_php4.c>

#php_value session.use_trans_sid 0

php_value register_globals 1

</IfModule>

 

tried every which way ..there does not seem to be a php.ini file, and I tried all the htacess files,read most of the forums - no conclusive answer...

 

cannot get past go!

thanks

russell

Rusty

-------------------------------------------

Link to comment
Share on other sites

by adding

php_value register_globals 1

 

to your .htaccess file should have solved that problem for you or move it to your first line at the top

 

so its not in between these tags <IfModule mod_php4.c> </IfModule> try that

Link to comment
Share on other sites

by adding

php_value register_globals 1

 

to your .htaccess file should have solved that problem for you or move it to your first line at the top

 

so its not in between these tags <IfModule mod_php4.c> </IfModule> try that

 

 

thanks steve

 

now i get an internal server error message, putting it at the top.

is this .htacess file in the catalog(that is the one I am doing ) but there is on in the

admin,?? what about the uncommented parts

 

 

below is the copy of my file, do you see any problems?

really want to get this working, my service provider seems to have all what i neeed to run,

 

thanks

//.......

 

# $Id: .htaccess,v 1.3 2003/06/12 10:53:20 hpdl Exp $

#

# This is used with Apache WebServers

#

# For this to work, you must include the parameter 'Options' to

# the AllowOverride configuration

#

# Example:

#

# <Directory "/usr/local/apache/htdocs">

# AllowOverride Options

# </Directory>

#

# 'All' with also work. (This configuration is in the

# apache/conf/httpd.conf file)

 

# The following makes adjustments to the SSL protocol for Internet

# Explorer browsers

 

<IfModule mod_setenvif.c>

<IfDefine SSL>

SetEnvIf User-Agent ".*MSIE.*" \

nokeepalive ssl-unclean-shutdown \

downgrade-1.0 force-response-1.0

</IfDefine>

</IfModule>

 

# If Search Engine Friendly URLs do not work, try enabling the

# following Apache configuration parameter

#

# AcceptPathInfo On

 

# Fix certain PHP values

# (commented out by default to prevent errors occuring on certain

# servers)

#

 

 

<IfModule mod_php4.c>

#php_value session.use_trans_sid 0

php_value register_globals 1

</IfModule>

 

...//

Rusty

-------------------------------------------

Link to comment
Share on other sites

try this in your catalog folder

 

# $Id: .htaccess,v 1.3 2003/06/12 10:53:20 hpdl Exp $

#

# This is used with Apache WebServers

#

# For this to work, you must include the parameter 'Options' to

# the AllowOverride configuration

#

# Example:

#

# <Directory "/usr/local/apache/htdocs">

# AllowOverride Options

# </Directory>

#

# 'All' with also work. (This configuration is in the

# apache/conf/httpd.conf file)

 

# The following makes adjustments to the SSL protocol for Internet

# Explorer browsers

 

<IfModule mod_php4.c>

php_value register_globals 1

</IfModule>

 

<IfModule sapi_apache2.c>

php_value register_globals 1

</IfModule>

 

<IfModule mod_setenvif.c>

<IfDefine SSL>

SetEnvIf User-Agent ".*MSIE.*" \

nokeepalive ssl-unclean-shutdown \

downgrade-1.0 force-response-1.0

</IfDefine>

</IfModule>

 

# If Search Engine Friendly URLs do not work, try enabling the

# following Apache configuration parameter

#

# AcceptPathInfo On

 

# Fix certain PHP values

# (commented out by default to prevent errors occuring on certain

# servers)

#

 

if still get internal server error look in you error log for what is happening

Link to comment
Share on other sites

try this in your catalog folder

 

# $Id: .htaccess,v 1.3 2003/06/12 10:53:20 hpdl Exp $

#

# This is used with Apache WebServers

#

# For this to work, you must include the parameter 'Options' to

# the AllowOverride configuration

#

# Example:

#

# <Directory "/usr/local/apache/htdocs">

# AllowOverride Options

# </Directory>

#

# 'All' with also work. (This configuration is in the

# apache/conf/httpd.conf file)

 

# The following makes adjustments to the SSL protocol for Internet

# Explorer browsers

 

<IfModule mod_php4.c>

php_value register_globals 1

</IfModule>

 

<IfModule sapi_apache2.c>

php_value register_globals 1

</IfModule>

 

<IfModule mod_setenvif.c>

<IfDefine SSL>

SetEnvIf User-Agent ".*MSIE.*" \

nokeepalive ssl-unclean-shutdown \

downgrade-1.0 force-response-1.0

</IfDefine>

</IfModule>

 

# If Search Engine Friendly URLs do not work, try enabling the

# following Apache configuration parameter

#

# AcceptPathInfo On

 

# Fix certain PHP values

# (commented out by default to prevent errors occuring on certain

# servers)

#

 

if still get internal server error look in you error log for what is happening

 

 

 

thanks steve

 

no change :(

 

error log does not say anything, only when I uncommented

 

like this

 

#<IfModule mod_php4.c>

#php_value session.use_trans_sid 0

php_value register_globals 1

#</IfModule> said something about

 

 

Invalid command 'php_value', perhaps mis-spelled or defined by a module not included in the server configuration

 

this what my isp is running , does this help,?

 

Operating system Linux

Kernel version 2.6.9-42.0.2.ELsmp

Machine Type i686

Apache version 1.3.36 (Unix)

PERL version 5.8.5

Path to PERL /usr/bin/perl

Path to sendmail /usr/sbin/sendmail

Installed Perl Modules Click to View

PHP version 4.4.2

 

 

what about adding the php.ini file?? where is this?

 

cheers

Rusty

-------------------------------------------

Link to comment
Share on other sites

thanks steve

 

no change :(

 

error log does not say anything, only when I uncommented

 

like this

 

#<IfModule mod_php4.c>

#php_value session.use_trans_sid 0

php_value register_globals 1

#</IfModule> said something about

Invalid command 'php_value', perhaps mis-spelled or defined by a module not included in the server configuration

 

this what my isp is running , does this help,?

 

Operating system Linux

Kernel version 2.6.9-42.0.2.ELsmp

Machine Type i686

Apache version 1.3.36 (Unix)

PERL version 5.8.5

Path to PERL /usr/bin/perl

Path to sendmail /usr/sbin/sendmail

Installed Perl Modules Click to View

PHP version 4.4.2

what about adding the php.ini file?? where is this?

 

cheers

 

 

PS

 

 

Something about this is a patch, not clear if take anything out or if this is the php.ini file,as other forums mentioned that,

 

php_flag register_globals on

where does this go?

thanks

Rusty

-------------------------------------------

Link to comment
Share on other sites

PS

Something about this is a patch, not clear if take anything out or if this is the php.ini file,as other forums mentioned that,

 

php_flag register_globals on

where does this go?

thanks

 

 

 

SORTED

 

Went to the patch files

 

http://www.oscommerce.com/community/contributions,2097 and downloaded them, and got the lastest version of osc.

just used the pre-patched files, and got the install screen, wooooohoooo, sure I be back!

thanks to all for the help;;

cheers

Rusty

-------------------------------------------

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...