Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Register Globals turned of by host


Guest

Recommended Posts

I have been reading the forums for some time now and I am lost. I am new to oscommerce. I am setting it up to switch from cubecart for lack of support and features. I just got an email a few weeks ago from my hosting company that says that they are turning "register globals" off for security reasons.

 

So, I get the following error after installing oscommerce via fantstico package -

 

"Server Requirement Error: register_globals is disabled in your PHP configuration. This can be enabled in your php.ini configuration file or in the .htaccess file in your catalog directory."

 

I have seen where some of the instructions say to edit the "php.ini" file in the catalog directory but I can not find a "php.ini" anywhere in the entire directory and i can not find the "catalog" directory.

 

I also have read that the "register global" setting is in the ".htaccess" fille and found the following setting within this fille in the admin directory of the oscommerce install-

 

#<IfModule mod_php4.c>

# php_value session.use_trans_sid 0

# php_value register_globals 1

#</IfModule>

 

I changed it to -

 

#<IfModule mod_php4.c>

# php_value session.use_trans_sid 0

# php_value register_globals 0

#</IfModule>

 

just to see if that would work but it did nothing so I changed it back.

 

Can someone point me to the area that give novice people decent instruction on getting this to work? I have read reeally good things about oscommerce's cart and I am dying to try it.

 

Thanks for the assist,

Brian

Link to comment
Share on other sites

I have been reading the forums for some time now and I am lost. I am new to oscommerce. I am setting it up to switch from cubecart for lack of support and features. I just got an email a few weeks ago from my hosting company that says that they are turning "register globals" off for security reasons.

 

So, I get the following error after installing oscommerce via fantstico package -

 

"Server Requirement Error: register_globals is disabled in your PHP configuration. This can be enabled in your php.ini configuration file or in the .htaccess file in your catalog directory."

 

I have seen where some of the instructions say to edit the "php.ini" file in the catalog directory but I can not find a "php.ini" anywhere in the entire directory and i can not find the "catalog" directory.

 

I also have read that the "register global" setting is in the ".htaccess" fille and found the following setting within this fille in the admin directory of the oscommerce install-

 

#<IfModule mod_php4.c>

# php_value session.use_trans_sid 0

# php_value register_globals 1

#</IfModule>

 

I changed it to -

 

#<IfModule mod_php4.c>

# php_value session.use_trans_sid 0

# php_value register_globals 0

#</IfModule>

 

just to see if that would work but it did nothing so I changed it back.

 

Can someone point me to the area that give novice people decent instruction on getting this to work? I have read reeally good things about oscommerce's cart and I am dying to try it.

 

Thanks for the assist,

Brian

 

Brian;

My host also has it set to off, I searched my email and came up with this link. Hope it helps you:

http://www.oscommerce.com/community/contributions,2097

 

 

Paul

Link to comment
Share on other sites

So that leads to another question: The PHP file says register_globals should definately be off and that you should write code which does not need it. Consequently, does that me that we should install the patch mentioned above and definately NOT set register_globals=on?

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...