Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Error codes


rachelp

Recommended Posts

Hi All.

I'm all new to this osCommerce (and websites) I'm haveing a problem after install , i followed all the instructions but at the top of my page i get these lines .

 

Warning: session_save_path() [function.session-save-path]: SAFE MODE Restriction in effect. The script whose uid/gid is 16817/16817 is not allowed to access owned by uid/gid 0/0 in /mounted-storage/home28b/sub004/sc25865-QFEL/www/includes/functions/sessions.php on line 148

Warning: session_start() [function.session-start]: Cannot send session cookie - headers already sent by (output started at /mounted-storage/home28b/sub004/sc25865-QFEL/www/includes/functions/sessions.php:148) in /mounted-storage/home28b/sub004/sc25865-QFEL/www/includes/functions/sessions.php on line 97

Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /mounted-storage/home28b/sub004/sc25865-QFEL/www/includes/functions/sessions.php:148) in /mounted-storage/home28b/sub004/sc25865-QFEL/www/includes/functions/sessions.php on line 97

 

Is this a bug or something to do with my web space provider , any info on resolving this would be great :)

Link to comment
Share on other sites

umm......about the first one, it looks like your server has got the setting SAFE MODE enabled, you should speak to your hosting company about turning it off or you can switch it off using an htaccess file. About the others....probably also thsafe mode setting but not sure

Menou and unome

Link to comment
Share on other sites

  • 3 weeks later...

My host has been making all sorts of fun changes to their php (yesterday globals, today safe mode stuff). I got the same error Rachel did when my host had changed safe mode settings and eventually found this solution: (thanks to Ian and Jason)

 

What's happening is that osc is no longer able to write to /tmp on the server. It does not matter if you have sessions set to mysql in your catalog/includes/configure.php file near the bottom (highly recommended on a shared server); sessions.php still queries for the directory.

 

Fix: Goto Admin / Configuration / Sessions and change the "Sessions Directory" to tmp (no slashes)

 

If you can't get into Admin, goto your Database Admin page (usually PhPAdmin app.)

Click on any table on the left hand side.

Click on SQL at the top of the screen

Overtype whatever appears in the SQL window with ...

UPDATE configuration SET configuration_value = 'tmp' WHERE configuration_key='SESSION_WRITE_DIRECTORY'

 

Click "go".

Meaningful. Creative. Change.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...