Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Error when trying to access oscommerce


glowpaint

Recommended Posts

Hello

When I try to access oscommerce admin or the main site on the server to set oscommerce up I get the following error.

Server Requirement Error: register_globals is disabled in your PHP configuration. This can be enabled in your php.ini configuration file or in the .htaccess file in your catalog directory

What is the exact text I put in php.ini.

I don,t understand what is the problem. Please help and thank you in advanced for your precious time.

 

Paul The Entrance Australia

Link to comment
Share on other sites

do i place this text "php_flag register_globals on" in both htaccess files (admin and root dir).

Also do I need to remove all orher text, first. I,ve tried some variations and still can't get access.

 

 

Try adding to htaccess file:

 

'php_value register_globals 0' (that's a zero)

 

Or create an additional file from wordpad and save it as:

 

.htaccess.txt

 

and input the same code.

Link to comment
Share on other sites

Whether you use php_flag Register_globals on or php_flag register_globals 0 will depend upon the type of Apache server your site uses.

 

If your site is on a Windows server then .htaccess doesn't work on Windows servers.

 

Uploading a file called .htaccess.txt won't do anything except cause an error with an invalid file type.

 

I think that what Bruce meant was (if your own computer won't allow you to create a .htaccess file) is to create a file called txt.htaccess, upload it to your server and then rename it once it's there to .htaccess.

 

Vger

Link to comment
Share on other sites

Whether you use php_flag Register_globals on or php_flag register_globals 0 will depend upon the type of Apache server your site uses.

 

If your site is on a Windows server then .htaccess doesn't work on Windows servers.

 

Uploading a file called .htaccess.txt won't do anything except cause an error with an invalid file type.

 

I think that what Bruce meant was (if your own computer won't allow you to create a .htaccess file) is to create a file called txt.htaccess, upload it to your server and then rename it once it's there to .htaccess.

 

Vger

 

 

Sorry. I probably shouldn't be offering help. I'm too much of a noob myself. Please follow the advice of this post instead.

Link to comment
Share on other sites

thank guyz

 

I'll try ur suggestions.

 

I was told by my host to add "php_flag register_globals on" to a php.ini file for both root and admin sections, but it didn't work.

 

I'll let you know if ur input works.

Apache version 1.3.34 (Unix) is ver

 

ok

 

thanks again

Link to comment
Share on other sites

I have tried to install 3 times now with fantastico and now once with manually installing oscommerce.

I get this result ?FATAL ERROR: register_globals is disabled in php.ini, please enable it!?

My web host suggested ?php_flag register_globals on? in a Php.ini file, But it still didn?t solve problem . I even added this line to the .htaccess file in catalog on server.

 

I have also tried as suggested ?php_value register_globals 0? and ?php_value register_globals on? and ?'php_value register_globals 1?

 

I can?t even find the php.ini file so I guess that the .htaccess file acts as it.

 

Web permissions set to 755

Apache version 1.3.34 (Unix)

 

Does anyone know the problem? I?m getting desperate to at least start setting it up

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...