Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Weird php exec command line issue


Guest

Recommended Posts

I've been struggling with a weird issue when performing command line calls in OSCommerce, dealing with the linkpoint api.

 

Basically the exec commands are not being performed and always return back blank values in the output array. I've tried variations on exec like system and shellexec in order to get this up and going. Curl_exec isn't working for me either.

 

It gets interesting because I separated out the code in a test php file and manipulated some data to be plugged into the calls and everything worked like a charm. It's almost like something in oscommerce is stopping the exec functions from being executed without any kind of error? It's a dedicated server that I have root access to, so any changes that need to be made, can be made.

 

Both exec and curl_exec work fine for me in the separate script (being run via cmd line with php x.php), so I am at a loss why they wouldn't be working inside the execution of the oscommerce module.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...