Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Beginner installation problem


bewheels

Recommended Posts

I am trying to set up OS Commerce locally. I am on a Mac and use MAMP (same idea as Xmamp for Windows). I have used MAMP for other things so I know it works.

 

When I go to open the start/install page I get the following:

 

Server Requirement Error: register_globals is disabled in your PHP configuration. This can be enabled in your php.ini configuration file or in the .htaccess file in your catalog directory.

 

I am not seeing this file.

I am not sure what I need to do with it when I find it.

Link to comment
Share on other sites

Not sure about MAMP but xampp you have to go to the config files and manually change the register_globals settings. I cant remember the folder though.

 

Eric

When I had made a local test site, I had to literally CREATE the php.ini file. It didn't exist so I just checked what was in my live site and copied/pasted it into my local catalog folder.

 

Kelvin

Link to comment
Share on other sites

When I had made a local test site, I had to literally CREATE the php.ini file. It didn't exist so I just checked what was in my live site and copied/pasted it into my local catalog folder.

 

Kelvin

 

 

Any chance you can pass a copy to me? I do not have a live site. I am trying to get a feel of OC Commerce before deciding to switch to it. And I need to develop it off line and then replace what is already being used.

 

I am hoping that once I have the file I will be able to see what/where to change it.

 

Any help here would be greatly appreciated. I need this working SOON! Things are in boarder-line crisis mode here.

Link to comment
Share on other sites

I'm not too familiar with the Mac setup, but on my local Linux testbox I just did a search for php.ini in the filesystem. It should be somewhere in the vicinity of your PHP installation.

 

When you find it (and it should exist) look for "register_globals". When you find it simply change its value from "OFF" to "ON".

 

I believe you can also set this setting for a directory hierarchy by using a user-created .htaccess or php.ini file but seeing as you're running the whole server it might just be easier to set the value for the whole server.

 

If you do want to use the .htaccess/php.ini method specific to a directory I'd suggest doing a search on the forums for "register_globals" and php 5; there's a few posts around on this topic.

 

Edit: I should also add that another option is to use the Register Globals Patch Contribution, but this is usually an option for where you don't have access to the PHP server config.

Link to comment
Share on other sites

Edit: I should also add that another option is to use the Register Globals Patch Contribution, but this is usually an option for where you don't have access to the PHP server config.

 

Well - I put in the patches (thanks for the link), however now nothing shows up. I just get a blank screen.

 

When I was creating the database for this I had to put in the number for tables. Not knowing what to put there. I put 99. I don't know if that would have any inpact or not, but I thought I should put that out there.

 

What am I missing?

Link to comment
Share on other sites

Hmm, I'm not sure if the number for tables has anything to do with it; I've never had to set that value in my case. :?

 

So now when you go to catalog/install you get a blank page (ie. you don't even get to Step 1)?

 

Maybe check what versions of PHP and mySQL you're running too. Not sure, but maybe that's causing issues.

 

Otherwise I'd restore your backup or use a virgin fileset (effectively backing out the register globals patch) and try using the local php.ini/.htaccess method.

Link to comment
Share on other sites

Hmm, I'm not sure if the number for tables has anything to do with it; I've never had to set that value in my case. :?

 

So now when you go to catalog/install you get a blank page (ie. you don't even get to Step 1)?

 

Maybe check what versions of PHP and mySQL you're running too. Not sure, but maybe that's causing issues.

 

Otherwise I'd restore your backup or use a virgin fileset (effectively backing out the register globals patch) and try using the local php.ini/.htaccess method.

 

I go http://localhost:8888/OS_Commerce_3/catalog/install

and get a directory with the folder "includes".

 

I open "includes" and see "application.php"

I open "application.php" and get a blank screen.

 

This is with a fresh/virgin version of OS Commerce.

 

I did find a php.ini file (I thought it was an included file of OSC so that is where I was looking).

But I can not open it.

So the .htaccess is not an included file with OSC either?

 

Any ideas on opening these files or anything else to get this working?

 

Right now I am running php5 but I have tried switching to php4 and get the same results.

 

Thanks for the helping me out btw.

Link to comment
Share on other sites

Small update. I didn't realize that the folder in the patch were not complete subfodlers but just parts.

So I did another clean OSC file set up.

 

Replaced the patch peices only.

 

Now it goes from http://localhost:8888/OS_Commerce_3/

to a directory with the catelog folder.

I open the catelog folder and get

http://localhost:8888/OS_Commerce_3/catalo...stall/index.php

 

But it is still a blank page

Link to comment
Share on other sites

For my local testbox I used PHP 5 and managed to get around the issues by editing the php.ini file for the PHP server. However, to avoid these issues on my domain I had my host install PHP 4.4.2 instead and this has avoided most issues.

 

But back to your specific problem, you should see the .htaccess in the catalog folder. If you can't then it's probably hidden so you'll want to make hidden files visible (not sure how you do this with a Mac :)). Once you can see it add the following two lines at the bottom:

php_flag register_globals on
php_flag register_long_arrays on

Resave the file and try again.

 

Btw, it seems strange that when you access the URL you posted above you get to the directory structure. I believe the file that needs to run is ../install/install.php So maybe try adding "install.php" explicitly in your url.

 

Failing this, I wonder if this could be an operating system type issue.

 

Good luck.

Link to comment
Share on other sites

Making progress but...

 

I started fresh again. This time I got the install window. Put in teh settings but got this:

 

A test connection made to the database was NOT successful.

 

The error message returned is:

 

Access denied for user 'databasename_1'@'localhost' (using password: YES)

 

Please click on the Back button below to review your database server settings.

 

If you require help with your database server settings, please consult your hosting company

 

I am unsure how to address this because the password and username are set by MAMP as "root" for everything. But the install does not seem to like this.

 

It was nice to see the install window though :)

Link to comment
Share on other sites

Got it.

I am in.

 

Thanks for the help. The patch is what really did it.

 

One last question:

How do you get back into the admin panel once I log out?

Is the password going to be "root" in this case (as mentioned above). I am more used to Joomla where you set a password separate from the database password.

Link to comment
Share on other sites

Got it.

I am in.

 

Thanks for the help. The patch is what really did it.

Congratulations! Glad to hear the success! :)

 

How do you get back into the admin panel once I log out?

Is the password going to be "root" in this case (as mentioned above). I am more used to Joomla where you set a password separate from the database password.

From memory, you don't have to enter a password at all to get to your admin panel; it's simply http://yourdomain.com/catalog/admin

 

So, initially it is unprotected. Should you want to protect it, as you probably will want to, just chuck an .htaccess file into the admin folder.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...