Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Am I stupid? I can't get oscommerce working???


Hexx

Recommended Posts

Hi guys! I'm just trying to install osCommerce to a Windows based server and when I'm done and things seems fine I get problems using the webshop as customer.

 

When I for exampel use the contact us form and press send I get this error

 

Warning: mail(): Failed to connect to mailserver at "localhost" port 25, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set() in C:\home\kunder\7361\*******.se\selkammaren\includes\classes\email.php on line 522

 

Warning: Cannot modify header information - headers already sent by (output started at C:\home\kunder\7361\*******.se\selkammaren\includes\classes\email.php:522) in C:\home\kunder\7361\*******.se\selkammaren\includes\functions\general.php on line 33

 

Anyone know what I could have done wrong ? The only thing I'm unsure about is

 

Webserver Root Directory:

 

Let's say my website is located on a webhotel in myweb/hell/catalog

 

Is that exactly what I should write there then ? I don't get it but it just talks about C:\home\kunder\7361\****** in all error messages and I don't understand why cause I have never stated that anywhere in the installation. Except that 7361 is my database ....

 

Thanks in advance!

Link to comment
Share on other sites

Is this server a localhost or do you have hosting on the internet?

 

oscommerce does not work on a windows server with asp it needs php and unless it is a localhost with php you have the wrong hosting package. You will need to be switched to a Linux server.

 

Good Luck you have a long road ahead of you.

 

 

Hi guys! I'm just trying to install osCommerce to a Windows based server and when I'm done and things seems fine I get problems using the webshop as customer.

 

When I for exampel use the contact us form and press send I get this error

 

Warning: mail(): Failed to connect to mailserver at "localhost" port 25, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set() in C:\home\kunder\7361\*******.se\selkammaren\includes\classes\email.php on line 522

 

Warning: Cannot modify header information - headers already sent by (output started at C:\home\kunder\7361\*******.se\selkammaren\includes\classes\email.php:522) in C:\home\kunder\7361\*******.se\selkammaren\includes\functions\general.php on line 33

 

Anyone know what I could have done wrong ? The only thing I'm unsure about is

 

Webserver Root Directory:

 

Let's say my website is located on a webhotel in myweb/hell/catalog

 

Is that exactly what I should write there then ? I don't get it but it just talks about C:\home\kunder\7361\****** in all error messages and I don't understand why cause I have never stated that anywhere in the installation. Except that 7361 is my database ....

 

Thanks in advance!

Link to comment
Share on other sites

I'm running on a webhotel with Windows serverand MySQL. Is this why I can't get it work good ? So I do need to be on a Linux server, right ?

 

Is this server a localhost or do you have hosting on the internet?

 

oscommerce does not work on a windows server with asp it needs php and unless it is a localhost with php you have the wrong hosting package. You will need to be switched to a Linux server.

 

Good Luck you have a long road ahead of you.

Link to comment
Share on other sites

What do you mean by a webhotel. Is it webhotel.net? If you are you need to have them switch you to their Unix server and see if that will work for you. Their windows server does not seem to have php enabled and therefore will not work with oscommerce.

 

 

 

I'm running on a webhotel with Windows serverand MySQL. Is this why I can't get it work good ? So I do need to be on a Linux server, right ?
Link to comment
Share on other sites

your server will have php otherwise you would not see the contact us page as it would not be interpreting the <?php tags

 

The warning

Warning: Cannot modify header information - headers already sent by (output started at C:\home\kunder\7361\*******.se\selkammaren\includes\classes\email.php:522) in C:\home\kunder\7361\*******.se\selkammaren\includes\functions\general.php on line 33

 

would suggest that you have looked into the file

C:\home\kunder\7361\*******.se\selkammaren\includes\classes\email.php

 

due to having received the error message and that this may have caused the introduction of whitespace after the last ?> on the file.

 

download and open the file includes\classes\email.php place the curser after the last ?> and hit delete to remove any whitespace.

No longer giving free advice. Please place deposit in meter slot provided.  Individual: [=] SME: [==] Corporation: [===]
If deposit does not fit one of the slots provided then you are asking too much! :P

Is your Osc dated try Phoenix  raising oscommerce from the ashes.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...