Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

cant log into admin


plum

Recommended Posts

I have exactly the same problem - on a server that has just been upgraded to PHP5 and MySQL5. I have been able to correct the various syntax errors in the main body of the site - but so far have not been able to get anything working in the admin section - after the password request (from .htaccess) the screen is blank.

 

Viewing source shows only the very top header - nothing more. Manually entering admin.php or index.php etc has no effect.

 

Appreciate any help from anyone that may have gone through this problem.

 

Thanks in advance

Link to comment
Share on other sites

I have exactly the same problem - on a server that has just been upgraded to PHP5 and MySQL5. I have been able to correct the various syntax errors in the main body of the site - but so far have not been able to get anything working in the admin section - after the password request (from .htaccess) the screen is blank.

 

Viewing source shows only the very top header - nothing more. Manually entering admin.php or index.php etc has no effect.

 

Appreciate any help from anyone that may have gone through this problem.

 

Thanks in advance

 

 

First things first. Go into .htaccess and remove the page protection. See if it loads that way. Are you sure it's the proctection that's causing the problem and not another conflict?

Just between us, remember there are only 10 kinds of people in the world; those who understand binary and those who don't!!

 

Remember, learning is a "do-it-yourself" experience; although, not necessarily a "do-it-BY-yourself" experience.

 

The quickest way to learn is to forget to BACKUP!

Link to comment
Share on other sites

If you have access to your server error log, you may find a warning like this:

 

PHP Fatal error: Cannot re-assign $this in ...\\admin\\includes\\classes\\upload.php on line 20

 

Commenting out line 20 (// $this = null;) seems to solve the problem, but I don't know if it will affect any of the admin functionality - if it does, I haven't spotted it yet, but then I haven't tried out backup, restore, easypopulate etc.

 

If someone knows how to amend the code so that it is php5 compliant, please let us know too.

 

Snoopy

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...