Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Sign in to follow this  
pankaj41483

Hi i have major problem with the Payment pro

Recommended Posts

Hi all,

 

i have amjor problem with the payment pro . asi have two server and i have installed on botth the server . and on one server there is no SSL and on that server my payment pro is working fine. and on emy seccond server wheer SSL is enabled . my site is running under the SSL . and on that Payment pro is not working .

 

i have all the setup and i am fullfilling all the requiremnt like

 

1- pear under catalog

2- curl Support

3- Open SSL

4- API suer name/Password

5- API Sertificate key

 

 

Everything is there .

 

you can check my url - www.alphaimports.net on this its is not working .

 

What is happening i am explaining you .

 

when we click on the Express button . its goes to the ec_process.php page and execute the code but after 1-2 seccond it show page cannt be found . when i try to debug the code i found that code on page is working paypal_wpp.php file is executed and the ec_step1() function is also excuted. but i think there is some problem with the paypal_init() function or any wher else. after ecliking the Express button itsexcte the code and after 2-3 seccond it shows the" page cannt found".

 

and seccond is my www.maniweb.net/newalpha/

 

here it is working fine. please help me . its very urgent . please help me .

 

help me help me help me. please i have looked all the files and checked all the things everthing seems perfect but its is not working .

Share this post


Link to post
Share on other sites

Hello,

Was just wondering if you figured this out. I had a customer call me up today for a 3764.00 order and he was trying but the error was the same: ec_step1()

 

Thank you!

 

Hi all,

 

i have amjor problem with the payment pro . asi have two server and i have installed on botth the server . and on one server there is no SSL and on that server my payment pro is working fine. and on emy seccond server wheer SSL is enabled . my site is running under the SSL . and on that Payment pro is not working .

 

i have all the setup and i am fullfilling all the requiremnt like

 

1- pear under catalog

2- curl Support

3- Open SSL

4- API suer name/Password

5- API Sertificate key

Everything is there .

 

you can check my url - www.alphaimports.net on this its is not working .

 

What is happening i am explaining you .

 

when we click on the Express button . its goes to the ec_process.php page and execute the code but after 1-2 seccond it show page cannt be found . when i try to debug the code i found that code on page is working paypal_wpp.php file is executed and the ec_step1() function is also excuted. but i think there is some problem with the paypal_init() function or any wher else. after ecliking the Express button itsexcte the code and after 2-3 seccond it shows the" page cannt found".

 

and seccond is my www.maniweb.net/newalpha/

 

here it is working fine. please help me . its very urgent . please help me .

 

help me help me help me. please i have looked all the files and checked all the things everthing seems perfect but its is not working .

Share this post


Link to post
Share on other sites

This is usually caused by a missing API certficiate. If you update to the latest version of the contribution, you can use the included wpp_diagnostics.php script to make sure everything's installed correctly.


Please use the forums for support! I am happy to help you here, but I am unable to offer free technical support over instant messenger or e-mail.

Share this post


Link to post
Share on other sites

Hello dynamoeffect, I know this works... it has worked perfect if the customer clicks on continue instead of checkout with Paypal Express.

 

He has been on my cart for 1.5 hours trying to process this order. I just called him.

 

Wish me luck... my 3rd sale and it will be 4103.00

 

Thanks for the contribe!

David

 

This is usually caused by a missing API certficiate. If you update to the latest version of the contribution, you can use the included wpp_diagnostics.php script to make sure everything's installed correctly.

Share this post


Link to post
Share on other sites

This order completed successfully, thank you dynamoeffect! You truely rock!

 

Wh00t!

David

 

 

Hello dynamoeffect, I know this works... it has worked perfect if the customer clicks on continue instead of checkout with Paypal Express.

 

He has been on my cart for 1.5 hours trying to process this order. I just called him.

 

Wish me luck... my 3rd sale and it will be 4103.00

 

Thanks for the contribe!

David

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×