Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

FATAL ERROR: register_globals is disabled in php.ini, please enable it!


olliel

Recommended Posts

In C:\Program Files\xampp\php\php4\php.ini find the line

register_globals = Off
, chane to
register_globals = On
. Assuming you switched to PHP4. If that does now work seach the entire XAMPP folder for ALL the php.ini files and make the change to all of them.
Link to comment
Share on other sites

There are a few places you can find that file. If you are using XAMP then it is most likely in the Apache folder. I had the same error when I first set up osC and that was the file I needed to change.

Link to comment
Share on other sites

New Registry_globals PROBLEM! Going around in circles....Heeeelp!

 

 

I am having the same erro about register_globals but if I change it I still get the same error. I have changed it on every php.ini file and still no joy.

 

Also I just found this online:

-------------

Some settings to consider when configuring PHP for security include:

 

1. register_globals: The boogeyman of PHP security is register_globals, which used to default to "on" in older releases of PHP but has since been changed to default to "off". It exports all user input as global variables. Check this setting and disable it -- no buts, no exceptions. Just do it! This setting is possibly responsible for more PHP security flaws than any other single cause. If you're on a shared host, and they won't let you disable register_globals, get a new host!

 

-------------

 

So even if I get it to work am I setting myself up for a security nightmare?

 

I look forward to some response.

 

Deano

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...