Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

HELP - xammp


olliel

Recommended Posts

Hi, i want to look at my oscommerce site, and am using xammp. I've created a file-zilla server, ftp-ed my oscommerce files over to /localhost (127.0.0.1) and that all seemed to work. But, now i want to view the site, how do I do it????

 

PLEASE HELP!!

 

 

thankyou

Link to comment
Share on other sites

You don't have to ftp if it is on your computer, just copy the files to the htdocs folder. To view your site you should just type in http://localhost to your browser and it should work. If you type in http://localhost/xampp/ you will get the XAMPP window.

 

Switch XAMPP to use PHP4, it makes it easier. How to do it is on the XAMPP site.

Link to comment
Share on other sites

You don't have to ftp if it is on your computer, just copy the files to the htdocs folder. To view your site you should just type in http://localhost to your browser and it should work. If you type in http://localhost/xampp/ you will get the XAMPP window.

 

Switch XAMPP to use PHP4, it makes it easier. How to do it is on the XAMPP site.

 

Hi, thats the trouble, i can't find the htdocs folder :s. Any help?

Link to comment
Share on other sites

C:\Program Files\xampp\htdocs

 

so.... drop catalogue fiel into htdocs, then make your spl server too on xammp. Then when you install type it all in, then you will be able to view it in a browser after that?

Link to comment
Share on other sites

drop the catalog folder into htdocs folder and then point your browser to http://localhost/catalog and you should see the install screen, if you have changed XAMPP to PHP4.

 

One last question now, i've been looking on xammps site and forums, its just all too vast, how do i change it to php4 ?

 

thanks

Link to comment
Share on other sites

Okay :'( I will look through the entire site for you. Go to http://localhost and you will see the XAMPP main window. In the Tools section you will see "PHP Switch". Try starting there. :thumbsup:

Link to comment
Share on other sites

Re. the switch, maybe this will help :) ...spax posted this the other day.

 

In your xampp directory, you will see a file named php-switch.bat

 

Make sure Apache is stopped and double click on php-switch.bat

 

That will bring up a command line prompt. Type in the number 4 and hit return, it will now switch to PHP4, just re-start Apache and you're done.

 

To change back to PHP5, do all the above again but enter 5 instead.

Link to comment
Share on other sites

Okay :'( I will look through the entire site for you. Go to http://localhost and you will see the XAMPP main window. In the Tools section you will see "PHP Switch". Try starting there. :thumbsup:

 

Right, i'm starting to get it now, sorry complete thicko at php. the only thing now is, i cant install the cart because it comes up with this.;

 

FATAL ERROR: register_globals is disabled in php.ini, please enable it!

 

I'm sure this is easy to correct ?

 

Thankyou very very very much

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...