Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

New install, SSL roadblock.


Apex

Recommended Posts

Hi all,

 

Let me start off by saying that the OSC install is fresh. I also installed the Register Globals 1.4a patch to clear that problem. The only issue now is that anything that is secure ie: checkout, My Account or even creating a new account shows this error on the bottom of the page "Error! Unable to determine link page!". I am stuck and have no clue in which direction to turn. Am I missing something here? Any help would be appreciated. :blush:

 

 

thanks,

Rafael

Link to comment
Share on other sites

I checked the path in both config files. I can go to the https side without a glitch ie: https://www.xfaktory.com/index.php. What I run into is the Error in the bottom of the page and anything secured will have that message. I tried to create a new user and after I filled the info and submit, it blanks out the info entered and goes back asking for the new user account info again.

Link to comment
Share on other sites

I found the problem. when I created the ssl cert, I was using php 4.4.2, then the server was upgraded to 5.1.2 so the cert did not match. I reverted back to 4.4.2 and it fixed the problem. just in case someone else runs into this Im just posting. Make sure you use the same php version when you create your cert!

 

- Rafael

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...