Jump to content
  • Checkout
  • Login
  • Get in touch


The e-commerce.

Customer Login don't work (cookie problem?)


Recommended Posts

Hi to all,

I've a little problem with the registration of a new customer / basket...the problem is that when I click on customer's login button, or I click on "buy now" button, OSCommerce redirect me to "cookies_usage.php".


In browser cookies are "always accepted", and I test it with IE7 anf FireWorks.

This is my configure.php


define('HTTP_SERVER', 'http://www.storeswiss.ch/'); // eg, http://localhost - should not be empty for productive servers

define('HTTPS_SERVER', ''); // eg, https://localhost - should not be empty for productive servers

define('ENABLE_SSL', false); // secure webserver for checkout procedure?

define('HTTP_COOKIE_DOMAIN', 'http://www.storeswiss.ch');

define('HTTPS_COOKIE_DOMAIN', '');

define('HTTP_COOKIE_PATH', 'http://www.storeswiss.ch');

define('HTTPS_COOKIE_PATH', 'http://www.storeswiss.ch');

define('DIR_WS_HTTP_CATALOG', '');

define('DIR_WS_HTTPS_CATALOG', '');

define('DIR_WS_IMAGES', 'images/');

define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

define('DIR_WS_INCLUDES', 'includes/');

define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');


and in COnfiguration session in Admin area I put "Force cookie use" to "True" and Recreate Session to "True".


I don't understand where's the problem! Please Help me!

Have a nice day to all!



Link to comment
Share on other sites

I would recommend setting "force cookies" to FALSE


Your cookie domain needs to be www.storeswiss.ch OR storeswiss.ch OR .storeswiss.ch (no http://)..any of those should work


If your store is installed in the root (not in a "catalog" or "shop" directory), your cookie path needs to be '/'




define('HTTP_COOKIE_DOMAIN', '.storeswiss.ch');



define('HTTP_COOKIE_PATH', '/');

define('HTTPS_COOKIE_PATH', '/');


and you should probably change this one too (i.e. put the / in between the single quote marks):


define('DIR_WS_HTTP_CATALOG', '/');

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...