Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Installation problems with Mp3_preview_with_Flash_player_v1.04


Guest

Recommended Posts

Hi forum,

 

Hope all is well, and your OSc stores are doing great business! :thumbsup:

 

I was hoping I could pick your collective excellence of minds, to advise me on something that is probably quite simple!

 

I'm trying to install the Mp3_preview_with_Flash_player_v1.04 contribution (link here) to my standard OSc site (paypal IPN & download controller contribs installed). I believe this contribution will stream the mp3 file through a flash player. I have got the right contribution haven't I? :o

 

Presuming that I have, I have managed to follow the installation instructions upto step 3. I ran the SQL file, so am I correct in thinking I don't have to worry about the instructions below?

 

3 - then execute the mp3player.sql file to your database .

or execute the command line below to your OSC database :

 

Note: the file catalog/admin/includes/configure.php and catalog/includes/configure.php have to be modified,

it's not fair to replace it because you would lose your configuration settings.

 

For catalog/admin/includes/configure.php

Add manually what is between //Mp3 player begin and //Mp3 player end

 

define('DIR_FS_CATALOG_MP3', DIR_FS_CATALOG . 'data/mp3/');

 

note this where u will upload the files u can change it for what u want . And don't forget to CHMOD as u'll get write permission on it

 

For catalog/includes/configure.php (new in v1.03)

Add manually what is between //Mp3 player begin and //Mp3 player end

 

define('DIR_FS_MP3', 'data/mp3/');

 

where the player will search your files . must be relative to your osc_player.swf file like this exemple or could be absolute . If u want to use it with absolute path it must looks like this :

 

define('DIR_FS_MP3', 'http://yourdomaine.com/mp3/');

 

 

Now basically this is where I'm at. When I goto add a product, I get an MP3 Preview | Browse option appear. Select it, pick file, and it manages to upload the mp3 to data>mp3. However, when I goto the product page on the site, no audio is played, nor mp3 player displayed.

 

If anyone could I advise me on what I should do or try, it would be much appreciated. I have know knowledge of flash, and my only PHP experience is through what I've done so far with OSc.

 

Thanks in advance :)

 

Tom

Link to comment
Share on other sites

I have not used the version of the player you are I am using version 2. However sounds like a problem I had,

 

I solved it like this:

In the configure files

define('DIR_FS_CATALOG_MP3', DIR_FS_CATALOG . 'data/mp3/');

define('DIR_WS_CATALOG_MP3', DIR_WS_HTTP_CATALOG . 'data/mp3/');

It should read:

define('DIR_FS_CATALOG_MP3', DIR_FS_CATALOG . '/data/mp3/');

define('DIR_WS_CATALOG_MP3', DIR_WS_HTTP_CATALOG . '/data/mp3/');

 

This will only effect the player on some servers but this small change makes the difference between it appearing and not appearing.

 

On my new server I had tow write the paths like this:

define('DIR_FS_CATALOG_MP3', DIR_FS_CATALOG . '/data/mp3/');

define('DIR_WS_CATALOG_MP3', DIR_WS_HTTP_CATALOG . 'data/mp3/');

Would not work any other way.

 

You might want to know about the support thread here:

http://www.oscommerce.com/forums/index.php?act...=7&t=122550

 

If you look at post 136 there is a link to the version 2 files.

 

Good luck

Backup before making changes. Backup before making changes! Backup before making changes!!

 

You did do a backup? eh?

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...