Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

error in your SQL syntax


Guest

Recommended Posts

When logged into the administraton part of my oscommerce website I receive the following message when I click on "Orders".

 

Could this be because no orders are placed? Or is this actually holding up order from being made?

 

Thanks for your help!!!

I'm not sure if you need that addy that my store is located on, bc I think you would have to be signed in as the administrator to get into this part but heres my domain/store http://computerzenabled.com/oscart

 

 

The following is the text that is displayed:

 

 

 

Orders

Order ID:

Status:

1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '-20, 20' at line 1

 

select o.orders_id, o.customers_name, o.payment_method, o.date_purchased, o.last_modified, o.currency, o.currency_value, s.orders_status_name, ot.text as order_total from orders o left join orders_total ot on (o.orders_id = ot.orders_id), orders_status s where o.orders_status = s.orders_status_id and s.language_id = '1' and ot.class = 'ot_total' order by o.orders_id DESC limit -20, 20

 

[TEP STOP]

Link to comment
Share on other sites

1064 - You have an error in your SQL syntax; etc ...

 

This SQL Syntax error is popping-up on my previously stable osC installations, and seems to be related to the Configuration / Maximum Values / Search Results setting.

 

Does anyone know what is causing this SQL Syntax error and the fix?

 

Thanks,

Eric

Link to comment
Share on other sites

I just found the answer here:

 

Cheers,

EricK

 

PS: Thanks Wendy!

---------------------------------------------------------------------------------------------

Here is the official fix:

 

Line 67 in catalog/includes/classes/split_page_results.php must be changed from:

$this->sql_query .= " limit " . $offset . ", " . $this->number_of_rows_per_page;

 

to:

$this->sql_query .= " limit " . max($offset, 0) . ", " . $this->number_of_rows_per_page;

 

Line 38 in catalog/admin/includes/classes/split_page_results.php must be changed from:

$sql_query .= " limit " . $offset . ", " . $max_rows_per_page;

 

to:

$sql_query .= " limit " . max($offset, 0) . ", " . $max_rows_per_page;

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...