Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

A tiny problem I think


Linxie

Recommended Posts

Ok, first hi... I am new. :)

 

Now, I installed OSC... made some minor changes, and got it how I thought I wanted it. Everything looked good. Then this morning I tried to do a test... any pages that require login come up as unavailable. I did not do anything to those files. They are exactly as they were to begin with. Below is what I have done.

 

Installed OSC

Modified the stylesheet, images etc.

configured the store in admin

removed a couple boxes from the right, moved one to the left.

added some external links into the info box.

and installed paypal ipn

edited the information pages with my info (man this thing don't like apostrophies)

... thats all

 

I did all these same things to another site with osc as well, and it is fine. Anyone know what I may have done, or how to fix?

Link to comment
Share on other sites

Usually when the login, checkout, or account related pages won't come up, it's because you have SSL enabled but you don't have an SSL certificate. So, it's trying to load an https:// (secure) page.

 

IF that's the case and you don't have an SSL certificate, go to catalog/includes/configure.php, find this line and change this:

 

define('ENABLE_SSL', true); // secure webserver for checkout procedure?

 

TO THIS:

 

define('ENABLE_SSL', false); // secure webserver for checkout procedure?

 

There's a similar line in catalog/admin/includes/configure.php and it should be changed to false also.

Link to comment
Share on other sites

OMG!! how simple and silly. I have no idea how I did that. I don't know you, but at the moment I could kiss you! I have been wracking my head all morning!

 

Thank you sooo much!

 

 

Usually when the login, checkout, or account related pages won't come up, it's because you have SSL enabled but you don't have an SSL certificate. So, it's trying to load an https:// (secure) page.

 

IF that's the case and you don't have an SSL certificate, go to catalog/includes/configure.php, find this line and change this:

 

define('ENABLE_SSL', true); // secure webserver for checkout procedure?

 

TO THIS:

 

define('ENABLE_SSL', false); // secure webserver for checkout procedure?

 

There's a similar line in catalog/admin/includes/configure.php and it should be changed to false also.

Link to comment
Share on other sites

OMG!! how simple and silly. I have no idea how I did that. I don't know you, but at the moment I could kiss you! I have been wracking my head all morning!

 

Thank you sooo much!

 

 

Thanks for your relpy, Crissy, but unfortunately I had these two items already set to "disable"... any other ideas?

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...